Arnova 7K G3/ model number AN7DG3C/ ARNOVA ChildPad/ ARM Cortex A8 @ 1 GHz

6 Questions View all

Why is my device not turning on?

I tried to turn on my tablet by pressing and holding the power/lock screen button, but my device didn't turn on. I have tried charging it and turning it on while charging but it still doesn't respond.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Allow the device to charge for 10 minutes before attempting to turn it on. While the device charges, there should be a light next to the power button indicating that the device is charging.

If the light doesn't turn on and the device still doesn't respond after 10 minutes, the battery is dead.

If the light does turn on then the device may have an unresponsive screen, and the screen may need to be replaced.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Tyler Sigafoose will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 4

All Time: 214