Model A1311 / Mid 2010 / 3.06 & 3.2 GHz Core i3 or 3.6 GHz Core i5 Processor

232 Questions View all

iMac chimes but display won't power?

Short version:

I have opened and closed my iMac (first time at repairing an iMac) and thoroughly check that all my cables are plugged back in, but even though the computer powers on and chimes (and all 3 LEDs are on), the display does not seem to be powering on at all.

I don't know what else to say, it worked fine before I opened and now it doesn't. I'm at a loss!

-

Long story (maybe some clues?)

When my mid 2010 i3 21.5" iMac's internal HD's smart status said it was failing I decided it would be a good opportunity to upgrade the storage and fix its broken supper drive.

Everything was supper simple (asides from the connectors being very stiff first time through) except for the display data cable, which popped off before I could see how it was attached originally.

I loaded in my new parts and proceed to close the machine back up. But the display cable gave to a world of trouble, I think mostly due to the cast I didn't/don't know which way it goes in. The flip down lock thing doesn't work very well and my cable had a kink in to that make the "plug bit" pop out very easily (the way it is kinked also made my confused about which way it was supped to plug in). I think I was trying to put it in backwards to start and after reading a bit more on line I am probably lucky I didn't brake the connector on the motherboard with all my pushing.

After trouble shooting for several days and popping and closing the machine 100 times I think I have the back of how to get Citi to stay now.

When I went to power the machine on, I heard the chime, and the computer working for a few moments and then nothing. The display did nothing. No indication that it is even on.

Long story short I put all the original parts back in and the display still doesn't do anything.

-

Other details:

-

  • I have checked the internal LED diagnostic lights and 3 of them are on when I power up the computer.
  • I don't have a mini display adapter to try a secondary monitor at the moment.
  • To the best of my knowledge the display data cable looks fine. But I can't find any good pictures online or information about what it is posed to look like or how it works. So I have uploaded some photos of mine. Doe these all look right?

Data Plug Side A: http://www.albertaweddingphotography.ca/...

Data Plug Side B: http://www.albertaweddingphotography.ca/...

Full Cable:http://www.albertaweddingphotography.ca/...

Data Socket: http://www.albertaweddingphotography.ca/...

LCD Temp: http://www.albertaweddingphotography.ca/...

Vsynk: http://www.albertaweddingphotography.ca/...

Power: http://www.albertaweddingphotography.ca/...

----

----

UPDATE:

Upon Closer inspection it looks to me like the plug on the data cable has been chipped and must be damaged.

Block Image

Block Image

Block Image

Block Image

---

Update # 2

I have tested the iMac with an external (only had a cathray tube monitor tube laying around to test with, Yuk!) and the new SSD is working great.

I got my new display cable in, it fits perfectly but to my dismay the display is still not powering on and the 4th LED is still not on! Any ideas what is going on? (Also checked the display settings and only the external display is being recognized by the computer)

So in way we're back to square one. The computer works, but the internal display does not... What should I try next?!?!?

Answered! View the answer I have this problem too

Is this a good question?

Score 3

Comments:

Hmm, the cable itself looks fine to me. Have you felt the slight click when you push it in?

by

I don't think so.

Which side of the cable should be facing out?

by

The hinge should swing towards you if I am correct.

by

The hinge swings both ways! :)

by

(See photos above in update)

I disconnected the display cable to better see what I was doing and to see if I could feel a click. When I plugged it in I noticed that one side didn't seem to insert fully. Unpin closer inspection and comparing to eBay picts I think 2 or 3 pins have been chipped off.

I was worried that the chipped part might be stuck i noted socket, but after blowing o the socket the plug seems to fit better...

So I think I need a new data cable!

by

Show 2 more comments

Add a comment

2 Answers

Chosen Solution

Yes, it does look like the cable is damaged. If you put the cable in the wrong way you could burn the connector and damage a few parts on the logic board.

Also note the socket plate (the last picture) the left side edge is bent out which explains why you don't have a tight fit any more as the detent buttons on the cable connector are held by the holes in this plate.

Carefully, tap the corner in a bit so you get the needed resistance. Not to much here! As you don't want to snap it off.

But before you order the cable without the display unit plug in an external display via the DVI port to see if the system is working.

Was this answer helpful?

Score 3

Comments:

Dan, I damaged one of these and after reconnecting it could not even get a startup tone. This is one to the poorest connectors I've ever seen on a Mac and the cable is to short to even get a look at what you are trying to do. If you disconnect the top you are installing it blind.

by

Ok, I have tested the iMac with an external (only had a cathray tube monitor tube laying around to test with, Yuk!) and the new SSD is working great.

Today I got my new display cable in, it fits perfectly but to my dismay there is not difference in the results! Display still not powering on and the 4th LED is still not on! Any ideas what is going on? What should I try next?

(Updated original question also)

by

Add a comment

Did this ever get resolved? Exact same issue here and unhappy wife ;)

Was this answer helpful?

Score 1

Comments:

We might be able to help with the Mac. Please give us the last four figures of your serial number so we know the make and model. As to the unhappy wife, there is no guide on how to fix her on this site. Maybe you should start a new question. Please give us his/her make and model number and age when asking your question.

by

Add a comment

Add your answer

thesallad will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 12

Past 30 Days: 26

All Time: 1,068