Model A1418 / Late 2012 / 2.7 & 2.9 GHz Core i5 or 3.1 GHz Core i7 Processor

111 Questions View all

Black stripe on the display

After replacing the HDD with the SSD, there is a black stripe on the display.

I was very careful and followed the iFixit guide exactly.

Did anyone experience something similar?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

3 Answers

Chosen Solution

Ouch! This is not good :-{

Sadly you damaged the display in the process of taking it off.

The 'Thin Series' systems are a bear to open, as the display assembly is glued (double stick taped) to the frame so in the process of taking it off you can damage it in prying.

Sorry, tIme for a new display assembly.

Was this answer helpful?

Score 4

Comments:

It's not any of the connectors? I should go for the entire panel?

by

No you can't fix the display unit its sealed. It's time for a new display assembly.

by

Thank you very much.

by

Add a comment

Hi Avr, same happened for my 27" iMac - did you get it fixed? Please give me details of how and how much did it cost?

Many thanks

Was this answer helpful?

Score 1

Comments:

Yes, I did. I purchased a new display assembly from ebay, but I think these guys have better solutions, although a little more expensive: http://www.thebookyard.com/product.php?c...

by

Add a comment

I understood that this problem happens if you go inside with the plastic card along the edges more than 1 cm. I inserted the card too much (14 mm) and I touched something that broke the display.

REMEMBER: when you try to remove the display DO NOT insert the plastic card along the edges for more than 1 cm.

At the moment i do not know if i will have to replace the screen or not. This could be a bad issue...

Was this answer helpful?

Score 1
Add a comment

Add your answer

avr will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 314