Screen blank when working in OSX but works fine under windows 8.1

MacBook Pro 13" 2011 A1278 (i5 processor)

Hi,

I have a problem with my MacBook Pro 13" I have partitioned the SSD drive with both Windows 8.1 and OS-X Yosemite. I use the option key to pick the OS I want to work in.

A few weeks ago I restarted my system at which time I could not see anything on the screen the lights on the keyboard came on as per normal and the fan was working.

I plugged in an external screen and it worked perfectly. Then I restarted again in Windows 8.1 and internal screen works, and so does external screen. But, systems internal screen will not work in OS-X. At the moment I'm using system only under Windows 8.1.

I took it to the "Genius" guys at the Apple Store they said it needs new board, and wanted $500 to fix it!

How can there be a problem with the board if it works with Windows 8.1 ???

I have a technical PC background but this issue I just don't understand. Someone out there must be able to shed some light to this issue.

Please help... Thank You

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Lets try resetting the SMC services. Follow this Apple T/N: Intel-based Macs: Resetting the System Management Controller (SMC).

Also check the systems firmware following this Apple T/N: EFI and SMC firmware updates for Intel-based Macs. Make sure it's upto date.

Let us know if this solved your problem.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Greg will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 67