Error 9 after leaving iPhone 5 plugged into MacBook Pro

Hi,

I recently bought an iPhone 5 on eBay because the owner couldn't get it to boot (the screen and back had been replaced - badly!). So I got the phone and took it apart to replace the battery. I noticed that two of the screws were missing (turns out they were rattling around in the phone) and the battery connecter on the logic board was battered. I replaced the battery anyway and restored the phone. It worked fine for about 6 hours and then I got the random shut downs when it hit about 30% battery. I read that this can be caused due to incorrect battery calibration so followed the advice of draining the battery and recharging it. *This is where things went south* I tried to leave the phone on but it would just turn off unless it was plugged into the USB on my MacBook Pro - so I decided to leave it plugged in but leave the Mac turned off. I left it overnight and came back in the morning to an iPhone with the flashing battery symbol I couldn't do anything until it was charged. I thought this was a good result until it got stuck in a boot loop. I managed to stop the boot loop but every time I try to restore I get an "error 9". It happens every time I don't get different errors just 9.

So I'm stuck on restore/DFU mode(s) unable to complete the restoration. I've tried another computer (Windows and Mac), another USB (8 in total on 3 different computers), and another battery, tried uninstalling iTunes and reinstalling, downloading the ipsw and doing it manually through iTunes. Nothing worked. Is there anything else I can try? Just to repeat the phone was working until it was left plugged in overnight, somehow this put the phone in a crazy boot loop.

Any help would be greatly appreciated.

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

I tried to kick it out of recovery with Redsn0w, it just changed to Apple boot logo loop and now I can't even get into recovery or DFU.

Can anyone help?

:(

by

Add a comment