The Apple iPhone 5s was announced on September 10, 2013. Repair of this device is similar to the previous models, and requires screwdrivers and prying tools. Available as GSM or CDMA / 16, 32, or 64 GB / Silver, Gold, and Space Gray.

3788 Questions View all

Touchscreen unresponsive after screen replacement.


A few months ago i dropped my Iphone and the screen and lcd broke, also the frame got a bit bent on the top. I got a guy in inonesia to replace the screen (digitizer) but he did not want to bend the frame back in place in case the motherboard would break. He also removed the metal frame on top of the lcd,digitizer and camera flex cable. The phone seemed to work just fine for about a week, but then one day the touchscreen started failing, I did a hard reset, and the touch screen started working again for a couple of minutes, but then it was unresponsive again, and after that i could not make it work at all, also the screen would not turn on. Because this had already happened my dad bent the frame a little to its original state and tried to put the screen apart and then put it back together to see if it wanted to atleast turn on, so it did. but only for a couple of hours because when he tried to turn it on the day after it wasnt turning on at all again. (we tried to unplug the cables and plug them back in again but it made no difference).

I tried myself to do the same thing a week ago, but the screen wouldnt turn on. but when i charged the phone it made "boink" noises and the pc recognized it, so I updated the phone, and tried to format it, but still there was no picture. I concluded that i had gotten a bad screen and decided to buy another one, Yesterday I replaced all the parts to the new screen, reseated the battery and put everything back together, and now the phone turns on to the 'slide to set up' front, but my touchscreen does not work at all.

i can't really find anything that helps me with the problem on google, i have tried hard reset, to reseat all the cables and the battery, but the touchscreen still doesnt respond. Also wanted to add that only the digitizer cable and the home button cable makes a clicking sound when i snap it on. Also, it doesnt seem to be any water damage to the phone.

does anyone have any ideas how to make the touchscreen work?

I'm sorry for the long post, just really frustrated and wanted to explain as much as possible :)!

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

Free shipping on all orders over $100 or containing a Pro Tech Toolkit!

Browse Our Store

3 Answers

Chosen Solution

Bad screens are a dime a dozen. In other words, you could have installed yet again a defective screen, and that's very common. Or it could have been damaged during installation, which is even more common.

Since you tried re-booting and re-seating, next step is to try a new known good screen. Don't pull on the screen while the cables are seated, you'll damage the new screen.

If the above doesn't help, it could be due to damage on the logic board:

A/ Damage around the screen connectors (you'll see something broken/damaged/missing if you good good magnification such as 10x or more)

B/ Or damage to other parts of the touch screen circuit on the logic board, which may be difficult to identify and repair.

Was this answer helpful?

Score 2


thank you very much :) tried to contact the seller, so hopefully we'll figure it out.. i just want it to work so badly!


Add a comment

Try a new display assembly or get it fitted by another company

Was this answer helpful?

Score 0
Add a comment

I've been suffering the same annoying scenario. Screens are always an issue, but even buying from highly rated companies doesn't save you from this annoyance. One company sent cracked screen - worse than what it was supposed to replace. Ordered from second company through Amazon and got a great looking screen replacement but led to the screen being un responsive to touch. Screen powers up, previous screen saver appears, good quality image and computer recognised it but alas still no active digitizer.

Checked the connection but cannot determine if that's the obvious cause I'd imagined. Off on off on slight seating click too.

Driving me nuts now.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Trine will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 5

Past 30 Days: 41

All Time: 4,948