Mid 2009 Model A1278 / 2.26 or 2.53 GHz Core 2 Duo processor EMC 2326

799 Questions View all

Sound from speakers is fine but, not earphones?

When I plug in earphones, sound continues to play from the internal speakers and no sound is heard in the earphones. I have tested a few different headphones but, the same thing happens. I am not sure what is wrong.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

I forgot to mention that I also do not see "Headphones" under the sound output in system preferences.

by

Add a comment
Black Friday
Broken doesn't stand a chance.

1 Answer

Chosen Solution

Within the phono jack is a set of contacts and a switch. It sounds like it has gotten damaged.

You'll need a flashlight and a toothpick see if you can look down into the outlets hole compare it to the another outlet from a second system.

If you don't have a second system to compare it to you may want to visit an Apple Store.

Sometimes you can fix the contact otherwise you'll need to replace the outlet which is a very big job! As the whole logic board needs to be taken out to either to be swapped out or to gain access to the connector block. Here's an image were you can see the block (the left most metal can) logic board connectors.

You may want to try using a USB to analog adapter if you really need the signal output.

Was this answer helpful?

Score 1

Comments:

Thank you for your great answer,Dan. I will look into the USB to analog adapter, usually I don't need to use earphones but, once in a while they are necessary, I think this is the best option for me. Thanks for suggesting that as well.

by

Add a comment

Add your answer

Alessandra will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 166