Released April 2010 / 2.4, 2.53 GHz Core i5 or 2.66, 2.8 GHz Core i7 Processors

502 Questions View all

Bluetooth no longer functioning after installing dual hard drives

okay so after sucessfully removing the optical drive and installing an SSD, with the help of your guide, (Thank you!) everything seams to be running smoothly except that my bluetooth is no longer functioning. I have gone back inside to disconnect and reconnect twice now, and I do not see any physical damage, however it is still not cooperating.

Has anyone else had this problem? Any advice would be very much appreciated!

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment
Black Friday
Broken doesn't stand a chance.

4 Answers

Most Helpful Answer

I would start by replacing the AirPort/Bluetooth cable 922-9296 as you may have damaged it in the process of taking it off.

Let us know how it goes.

Was this answer helpful?

Score 2

Comments:

The airport is still working completely fine though, if the cable was damaged wouldn't both the bluetooth and wifi be out of commission?

by

Not necessarily. Its the only thing you pulled off to get to the optical drive bay. Did you slip and nick something with your screwdriver on the AirPort card?

by

Add a comment

There is a piece of black tape that goes over the pins of the wifi/bluetooth/webcam connector. Then, sometimes, there is this little mesh blob thingie that goes on top of the connector/cable.

If the black tape is no longer there, but you put the mesh blob thingie back, it will short pins of the connector. So toss that little mesh thingie in the trash and you will probably have a working setup back.

Was this answer helpful?

Score 1

Comments:

"little mesh thingie" Louis are you talking about the EMI shielding pad which is conductive? Yes! I agree, you do need to make sure it's not shorting out the board.

by

Add a comment

Hi there,

I have the same problem after installing a SSD. The old HDD replaced my optical drive. I replaced the Airport / Bluetooth Card (to the ...CAX one - to use hopefully handoff) without success. Next step was to replace the flex cable... Still the same Problem. WiFi works without Problems, only Bluetooth is not available.

PRAM, SMC reset didn't help either.

Has anybody an idea?

Was this answer helpful?

Score 0

Comments:

Does Bluetooth services work at all? If you are having problems setting up Handoff you should review this: Continuity Activation Tool

by

Are you sure you have the antennas correctly connected? It you are switching the board out the connections are laid out differently between them.

by

Add a comment

Thanks for your reply!

@Dan, Bluetooth is not working at all. I checked the wiring and connected them as described in Mid-2010 MBP upgrade success (MacBookPro6,2)

@Louis Rossmann

I'm not quite sure what you mean with "little mesh blob thingie". Can you see it on the picture?

Block Image

Was this answer helpful?

Score 0

Comments:

Did you try a different board? Maybe this one is bad.

by

Add a comment

Add your answer

acacella7 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 130