Model A1369, 1.6, 1.7, or 1.8 GHz Processor, 64, 128 or 256GB Flash Storage

249 Questions View all

connecting to mother board

I bought a new battery and having a VERY difficult time pushing the connector of the battery all the way into the port on the mother board. The original battery didn't have a problem. Am I doing something wrong? Shouldn't the lip of the port and the "ledge" around the battery be flush?

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Most Helpful Answer

Examine the battery connector tip. Does it have any issue such as any bent prongs that prevent the connector from sitting in place?

Also, are you sure you got the right battery model?

Was this answer helpful?

Score 2

Comments:

When I looked at the connector tip, it only has holes for prongs to go in. I didn't see anything wrong. And, I was able to get it to connect (Mac is saying it is charging) but after pushing really hard. It still doesn't fit flush though. And, I bought 2 of the same batteries, and both are really difficult to push in. So, I am guessing nothing is bent. Also, the batteries have the same model number on them that my original one has.

Here's the battery that I bought:

http://www.amazon.com/gp/product/B00MLSK...

I did contact the supplier and they are sending me out another one, but I am thinking this is a design issue that they have not resolved.

by

Seems like others reported similar issues. Must be a design flaw.

by

Add a comment

Add your answer

Tony Padgett will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 62