2.2, 2.4, 2.5, or 2.6 GHz Core 2 Duo processor

925 Questions View all

White screen, but works fine with an external monitor.

My A1226 MacBook Pro display screen went white when i pulled out the power cord one day and has not worked since.

It works fine with an external monitor and the screen brightness keys make the display brighter and dimmer as expected.

It shuts down when i press power then enter (dont know if this is relevant thought i read somewhere it maybe)

i have just changed the display data cable, but still have the same fault.

I don't know if i want to buy a new screen if it will not fix it. Is there some other test i can do to determine the fault?

Thanks!

Answered! View the answer I have this problem too

Is this a good question?

Score 2

Comments:

Have you checked your LVDS connector? Check the pins on it and take a look to make sure that none is missing or shortening it out. Obviously the backlight works, that is what provides you with the white light, but you are not getting any video signal.

by

OT, I was thinking the same thing but he pulled the power cord when it happened which got me thinking SMC and/or the loss of PRAM power. He did replace the cable which could have introduced a new problem too.

by

Hi , this turned out to be the logic board , the guy i got the spare parts off

to try said he would put money on it being the logic board , and he took all the

parts I didn't need back , very helpful chap.

I'm sure I read somewhere that

there is a fuse on the logic board for the display , I would like to repair my

board if possible as it was an upgraded board (invidia issue) and also a 2.6 ghz

the replacement I got was 2.2 . .

Any idea where this fuse is ?

Thanks

by

Greetings! Same thing is happening to my A1226. Screen goes white. I changed one of the the screen cables that connects on the logic board and after it worked fine. Recently, it did it again. I closed and opened the lid and it came back to normal. So, I am going to check the other two cables that connect on the i/O board the blue and the black one. Also will check the inverter board with cable too.

by

Add a comment

5 Answers

Chosen Solution

this was a fault with the logic board .

Was this answer helpful?

Score 0
Add a comment
Most Helpful Answer

Since you do have an image on the external monitor thats a good sign the issue is localized to either the internal display circuits or the systems settings. Lets try a few things here:

First lets do a SMC reset. Follow this Apple TN: Intel-based Macs: Resetting the System Management Controller (SMC).

Next, I would check the systems firmware making sure it was current. Follow this Apple TN: EFI and SMC firmware updates for Intel-based Macs.

Given the age of your system it's also likely the PRAM battery needs replacement. Follow this IFIXIT guide on how to replace it: MacBook Pro 15" Core 2 Duo Models A1226 and A1260 PRAM Battery Replacement.

I'm sure your display should be working at this point. If not its not good ;-{ You likely need a new display.

Was this answer helpful?

Score 3

Comments:

Hi , tried the smc reset both the firmwares seem current . and the pram battery is testing at a steady 3.2 V so i assume this is ok . i also swapped the left i/o board and this did not cure the fault ..

by

Not good ;-{ its starting to sound like the display is gone. Carefully check the display cable it might be frayed around the hinge. If you're upto it you could try replacing the cable first.

by

Add a comment

I'd do what Dan says first. That failing, I have had good luck in cases like this by replacing the left I/O board.

Was this answer helpful?

Score 2

Comments:

If resetting the SMC doesn't solve the problem, most likely this is the offender.

by

Hi , i have swapped the left i/o board no change , the pram battery is testing at a steady 3.2 V so im assuming this is ok ,.

so is it probable the display is at fault ?

by

Add a comment

Thanks for the replies guys , ive done the smc reset , also the efi and smc firmware appears to be correct versions ,

What kind of battery is inside the blue plastic of the PRAM battery can one be soldered in as i can only find a used one on ebay ,.

I cant believe the local apple repair center class this as "vintage" and won't repair it !! .

I will have a look at the LVDS connecter tonight when there are less little inquisitive fingers around !! , I have a usb microscope somewhere i will try and dig it out and have a good look .

I presume its a case of changing different parts until i find the culprit ?

It did have a new mainboard under the invidia chip problem , in 2011 i think it was ..

thanks for your help ..

Was this answer helpful?

Score 0
Add a comment

It is highly unlikely that the LCD is the problem. 99.999% of the time if it is faulty you will get something other than a blank white screen. Inspect the cable ends and the sockets they plug into on the boards. Look for corrosion or black burn marks with a magnifying glass of 5x or better. If you find any clean it off. You can use an emery board or sand paper on the male parts. Usually you can get by with a sewing needle on the female socket, a small dremel grinder tool is better (using it with your fingers not with the motorized dremel tool). Check for continuity on LVDS cable, also the left IO cable between it and the logic board with a multimeter. I've seen a burnt connection for the IO cable cause similar problem to this. Since you have replaced the left IO board, with a known good one? I would suspect the problem is a bad connection, bad left IO cable, bad LVDS (video) cable, or the problem resides on the logic board. Confirm your cables and their connections are good. If by small chance the problem is on the LCD, it will be some blown component(s) on the controller board attached to it. You should be able to get it fixed at a local tv repair shop cheaper than buying another LCD. Also see Ben Eisenman's answer white screen.

Was this answer helpful?

Score 0

Comments:

Hi , this turned out to be the logic board , the guy i got the spare parts off to try said he would put money on it being the logic board , and he took all the parts I didn't need back , very helpful chap. I'm sure I read somewhere that there is a fuse on the logic board for the display , I would like to repair my board if possible as it was an upgraded board (invidia issue) and also a 2.6 ghz the replacement I got was 2.2 . . Any idea where this fuse is ? Thanks

by

Add a comment

Add your answer

markparnell1972 will be eternally grateful.
View Statistics:

Past 24 Hours: 4

Past 7 Days: 25

Past 30 Days: 110

All Time: 2,733