Model A1297 Unibody: Early 2009, Mid 2009, Mid 2010 & Late 2011

424 Questions View all

LCD Replacement Problem ( No Power )?

What could have gone wrong?

Yesterday, I ended up fixing my broken LCD which only showed a white screen due to the cracks on the left of the screen.

Following the guide here on iFixit, everything went as perfectly as it could. Cables are all in perfect shape, connectors are just like I found them.

But finally once I boot it up, nothing happens on display. Computer boots perfectly, sounds, fans and everything but the LCD. The only thing I can think of is that I put the connector in the back of the LCD loose but wouldn't I still get some kind of sign of power? What should i do? I have a theory that if I disconnect the LCD cable from the logic board and boot it. Would it detect that the LCD isn't plugged in? Then try putting the LCD connector in and hope for a miracle?

Today I'm going to take it apart once again and let you guys know if anything turns up.

Thank you in advanced for any help!:)

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Have you checked with an external monitor to see that you have video signal at all? What are the last four digits of your computers serial number? That will help us to determine the hardware on your computer. What is the panel number of the LCD that you replaced vs. the new one?

by

Add a comment

1 Answer

Chosen Solution

Thank you oldturkey03 for the help, but i figured out the problem. Apparently the cable that connects to the lcd wasnt connected at all. So friendly tip for anyone with my same problem, the cable does come out Easily when reassembling so make sure to check to make sure and be careful always.

Was this answer helpful?

Score 2
Add a comment

Add your answer

Jesus Vazquez will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 39