Model A1369, 1.6, 1.7, or 1.8 GHz Processor, 64, 128 or 256GB Flash Storage

249 Questions View all

Unresponsive keyboard & trackpad

MacBook Air "Core i5" 1.7 13" (Mid-2011)

This MacBook air was working fine. No water or other liquid spilled. Just out of the blue, the keyboard and trackpad just became unresponsive.

It gets a connection with bluetooth device dialog window, and that works externally with USB with no problems.

Now in the system preferences you can't change anything, only gives you the bluetooth options?

There are no options to change any setting, such as ignore trackpad etc in universal access etc.

SMC & PRAM do nothing, Safe-Boot, does nothing, its in all users, so its system wide

Tried upgrade to Yosemite, no change.

Checked all hardware, removed battery checked cables and connectors all looks fine. Can't see any damage scratches or pollution?

So my next step will be erase and clean install, not from Time machine back up to see if that helps.

My question:

How can this happen, and why does it get stuck on the bluetooth dialog window and is there a way to re-activate missing preference settings such as mentioned above.

It puzzles me how that can just disappear. Any info is welcome

I'll keep updating this as far as it goes, I did come across a few similar situations online, but not with clear details on my question.

Thanks in advance

Daniel

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

i forgot to add that the power on button works,and so does the backlight of the keyboard..

by

Yeah so clean OSX instal did help for a period of 10 seconds than again Bluetooth connect dialog came up and no way around it,also in preferences still no option to change ignore trackpad option to de select…

Will probably try change keyboard/trackpad and see what happen.

strange problem.

by

Add a comment

2 Answers

Chosen Solution

Sounds like the ribbon cable connection from the keyboard to the logic board has come loose or damaged.

Follow this IFIXIT guide: MacBook Air 13" Mid 2011 Upper Case Replacement

Follow Steps 1 ~ 3 then jump to Step 17 removing the battery. Then continue through to Step 19 & 20.

Look to see if the cable is damaged or was not seated squarely.

Carefully unlatch the ribbon cable connector and using some tape attached to the ribbon cable careful pull the ribbon cables out inspect them and again using a piece of tape to help pulling the cable back in to the connectors reset them. put things back and see if that fixed things.

Was this answer helpful?

Score 1

Comments:

HI thanks for your reply,i checked already..the ribbon is fine.

by

Then I suspect something was spilled into the keyboard at sometime. Sadly, its a big job to replace the upper case.

by

But depending on what you spilled, you might be able to save it and save a lot of money. This guy is brilliant -- if your liquid was sugary, fix by drowning your Mac. Worked for me and lots of others. https://www.youtube.com/watch?v=tE5QRk1Q...

by

@runningtab - Steven Meltzer

He's almost right!

First its important to use Distilled Water not tap! To clean your system. While his water maybe more pure where he lives, most of us have minerals and other stuff coming out of our taps which can harm your system once it dries.

As to what was spilled is more than the sugars, it's also the acids the drink has in it that can damage your system. Don't forget about Ocean, Sea, Lake, Pond or rain water all has other stuff that will harm your system so you need to flush your system out when you get it flooded with these as well.

Lastly, if you can't get your system cleaned quickly, disconnect the battery ASAP! Wipe off as much of what ever was spilled, and keep your system as cool as you can (don't freeze it) this will slow the chemical reactions until you can address things properly.

by

Add a comment
Most Helpful Answer

I had a similar problem with a 15" MacBook Pro i7, no response from the trackpad and keyboard, no green light on the "caps lock key" only the power on button was functional. Replacing the trackpad and cable solved the issue for both the keyboard and trackpad functions.

Was this answer helpful?

Score 3
Add a comment

Add your answer

dani will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 14

Past 30 Days: 25

All Time: 1,232