Wifi Problems with Same Parts, but Different Shell

Here is an interesting problem that is really baffling me.

I use the same parts for the components for the wifi/webcam that is on a MacBook Pro (Wires and all), but when I place them in a different display shell it doesn't work, but when placed back in the original shell it does.

Swapped shells because the old one was damaged and had one in decent shape laying around.

Any suggestions?

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Might be a silly question but did you verify the new shell had the correct drivers? are you only replacing the shell and nothing else? such as motherboard, HDD ect.

by

Like I said, all I swapped out was the top half and I took all the wires, cards, and LCD Screen and placed them in the new shell.

So all the parts should be fine. That's where I'm confused.

by

The guys are the same, just moved. The shell was from another MacBook of the same size, but since the guts were a 2011 MacBook parts, I took those out and put the 2009 guts in. His includes the iSight board, airport, blue tooth, all that and the wires. So logically this shouldn't be happening.

by

Add a comment

1 Answer

Chosen Solution

If the boxes are different years you may have a problem with the card not being supported.

When you check the System Information-Network:WiFI does it recognize a card as being mounted? And of course you remembered to remove the old WiFi network service from System Preferences-Network, and create a new one for the new setup?

If this answer is acceptable please remember to return and mark it accepted.

Was this answer helpful?

Score 1

Comments:

Sorry took so long, had to get the video working first, and now that that works I checked the Preferences and it has Wifi greyed out.

by

Check System Information - that is where the computer detects hardware at boot. If it's not detected then of course you can not create a service in network. The reason it might not be detected could be a bad slot or card. (Not too long ago someone here had a problem of an undetected card and it turned out one of the connector pins was bent. He was able to realign it without breaking it off and all went well).

by

Wifi: Software Versions:

CoreWLAN: 5.0 (500.35.2)

CoreWLANKit: 4.0 (400.35)

Menu Extra: 10.0 (1000.33.2)

System Information: 9.0 (900.9)

IO80211 Family: 7.0 (700.52)

Diagnostics: 4.0 (400.68)

AirPort Utility: 6.3.4 (634.17)

This is what it says for the 'Wifi' section. When I had this in the other top shell it said this and the network data.

I ordered a new Wifi Antenna, just incase, since I found them off a supplier site for $1, $5 after taxes and all that though.

by

Under System Preferences->Network: on the left column did you hit the + at the bottom and create a new service for Wi-Fi and then enable it?

by

I did and Wifi doesn't show up. Just Bluetooth (PAN and DUN, Ethernet, and FireWire.

by

Show 7 more comments

Add a comment

Add your answer

Kenneth Curtis will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 149