Released June 2012, Model A1278. Intel processor with Turbo Boost, Up to 512 MB DDR5 Video RAM

785 Questions View all

Fast fan, sluggish computer

I have a problem with my mac. It's a mbp 13" mid-2012 that I have customised by adding RAM (16gb total) and an SSD (samsung 840 pro), and placing the original HDD in a optibay. Worked fine for a while, then had some problems that were fixed by replacing the data cable of the SSD.

This time I just came back from a 2 weeks holiday to find my mbp very slow and with the fan running at full speed. My first thoughts were to reset the pram (which didn't improve anything), and check the ssd cable again. So I opened the case, took the ssd out of its bay and mounted it externally via usb, in an external case... This had worked in the past when I had the cable problem, but didn't work this time. I've also tried another external disk where I have a fresh install of osx to use in emergency situations, and yet nothing... So it doesn't seem to be the cable, nor the disk. A disk speed test performed quite badly though (20mb/s).

Apple Hardware Test took long time for hardware probing, and finally (with the quicktest, the extended is being performed right now) reported this error:

4SNS/1/C 0000008:TAOP--124

Any suggestion?

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Chosen Solution

Give this a read: How to invoke and interpret the Apple hardware tests. While its a bit dated it still will give you a good idea on many conditions.

Lets tear into your 4SNS/1/C 0000008:TAOP--124 AHT error

4SNS - System sensor

T - Temp

A - Ambient air sensor

Given your systems slow down and the fan going full throttle this is an expected error. So it doesn't help localize the root issue.

Lets see if we can do some other diagnostics to help here. I would download this app: Temperature Gauge Pro. It can better identify what the different sensors are doing.

I suspect you have a known issue here which is the optical drives SATA port is not able to support your HD SATA speed. Review this: OWC Data Doubler. Note at the bottom of the pages (you'll need to scroll down) in Red the following:

Testing has demonstrated that Apple factory hardware does not reliably support a 6G (6Gb/s) Solid State Drive or Hard Disk Drive in the optical bay of 2011 MacBook Pros (ModeI ID8,1; 8,2; 8,3). If your OWC Data Doubler bundle comes with a 6G drive, you should ONLY install that drive in the main drive bay and utilize the Data Doubler to re-task your existing drive or install a new 3G SSD or HDD in the optical bay. PRE-2011 models can utilize a 6G drive in the optical bay, but will do so at a reduced 3G (3Gb/s) speed.

While you do have a '12 model the issue is still present and it makes no difference who's HD carrier you use as the issue is within the systems controller chip not the carrier.

OK, how can you prove this?

The thermal sensors should show the CPU & HD are running hot. Using Apples Activity Monitor You should see the indexer process is using a lot of CPU cycles with most everything else almost no cycles.

What is happening is the system is unable to read/write data to the HD reliability. If you kill the indexer process your system should cool down as long as the process is stopped. This is the symptom of a mis-matched SATA I/O channel. You'll need to look into getting a slower SATA spec'ed drive: SATA III (3.0 Gb/s) Vs the SATA III (6.0 Gb/s) drive you currently have (the original Apple drive).

You do want the process to run so you can't kill it as your file system requires it. You do need to address the I/O channel issue.

You can place the HD externally using a USB or Thunderbolt connected case to house the drive as a short term solution.

Was this answer helpful?

Score 3

Comments:

Thanks for your answer. I had done some search myself and figured out about the sensor.

That said I'm afraid it is not related to the disks:

1) it worked with ssd+optibay for over 1 year

2) i had found out over 1 year ago about the problem you mention as I had tried to put the ssd in the optibay, and it wasn't working. switching the drives solved the problem.

3) I tried with only the SSD (both internal and external), disconnecting the HDD (in the optibay), and I still had the problem.

4) I had just checked activity monitor and the process taking 300% of CPU is kernel task.

Also, Athere's no actual temp issue. The problem arised immediately after turning on the mbp that had been left home (and off) for 2 weeks...anyway the bottom of the mbp it is quite cold (not even warm).

I'm afraid the sensor might just be broken, although I can't figure out how.

Since I have limited internet acces, could you please help me locate the sensor? Just to visually check it, and understand if it's easily fixable.

Thanks!

by

I've also seen the kernel task issue as well with the SATA problem and I've seen it pop up later when an fair amount of data churn has happened (seemed fine day one or many weeks later). Did you do a large copy of some files onto the disk or delete them from the disk?

by

Do download Temperature Gauge so you can see which sensor is popping the error. Here's a good Apple TN: Mac notebooks: Operating temperature and this one: Runaway applications can shorten battery runtime, affect performance, and increase heat and fan activity. Which I think is the direction you will need to look with the kernel process taking 300% of the CPU.

by

No large copy, at least not in the last 15 days... As I said I came back from a trip, took the mbp that I had left home, turned on and immediately got this problem.

I think I did copy some large amount of data on an external HDD before leaving indeed, but not sure the things can be related ( it was 15 days ago).

I will try to download Temperature Gauge later maybe...

by

I still have the problem even with completely disconnected drives (i removed the optibay and the ssd).., so it does't seem related to me.

Might just be a broken sensor? Can I replace it myself? What else?

by

Show 8 more comments

Add a comment

Add your answer

guidoz will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 3

All Time: 543