Audio but no video

My Mitsubishi TV WD- 60735 has audio but no video after replacing the lamp.

Can you tell me what to look at, I checked my ballast and that is fine.

What else can I check or need to do to get the video?

I am using a cable box without HDMI inputs.

Thanks!

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

Michelle, just for clarification. Why did you change the lamp? did you have the same issues with your TV before you changed the lamp or is this a new finding? Do you have any error code coming from the front LED Indicators?

The front panel LEDs provide an indication of the set’s operation, and the possible cause of a malfunction. There are three

front panel LEDs, “Power”, “Status” and “Lamp”. The LED display shows the current status or indicates a possible

malfunction.

by

Get the shutdown error code-

Make sure lamp, lamp door, back cover, etc is installed properly.

Plug in TV.

After TV initializes press power to turn it on.

The TV should try to turn on a few times then shutdown with the red light.

Go up to the front panel on the TV, press and hold MENU + DEVICE (INPUT) until a light on the front starts blinking a two digit code like 3 blinks pause 4 blinks repeat or similar. Let us know what you find.

by

Oldturkey03, first let me say thank you for replying to my question.

I change the lamp because I was getting a failed lamp code (I forgot what it was but the lamp was bad)

I am no longer getting any red or yellow codes after I changed the lamp and it stays on.

I get a steady green light (status) The TV turns on and off normally by either the remote or the front panels.

I went ahead and press the menu and input key to see if I would get an error code and the only thing that occurred

was 1 green blink and then 2 green blinks. TV stayed on.

Does this help?

Thanks again.

by

I gave you the wrong green light, the light that stays on until I turn off the TV is the Timer light, the status and lamp light are not lit.

When I had the lamp problem I believe it was Red. Don't remember now but I do know the error code pointed to the lamp being bad.

by

I guess you know already that I can't see the setup screen to change anything as well but I thought I would mention it.

by

Add a comment