Buttons and clickwheel frozen. Only Menu+Select combo works.

Greetings,

I got my hands on 2 Sad face iPod Videos. Both iPods work with a spare HDD, but one of them has an issue. The buttons and clickwheel are not responding. The only thing that works is the Menu+Select combo to reboot the iPod, and nothing more. No Disk mode, no Diagnostic menu, no Backlight when pressing buttons. I found a missing component, but i can't make out what it is. I'd appreciate if someone can help mi with this.

Here is a link with a picture.

Block Image

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

I am having the very same issue. I am not sure when it happened since it is always plugged into our Bose sounddock, but when I went to choose a playlist, I got no response from any of the clickwheel/buttons visible on the menu. I tried the reset which worked, but didn't fix it. I also tried to boot to disk mode after a reset, but that didn't work either. I can manage music fine on iTunes, and because it works with the Bose remote, I can still play, pause, and skip forward/backward, but unfortunately I can't change any of the menu options (like switch playlists, change EQ, etc, basically all options involving input from clickwheel/buttons). It is not a HD issue, not a button issue (since the reset worked), so I am assuming it is either firmware or a logic board issue. I have tried restoring it, to check if it is a firmware issue because I am a little apprehensive about what might happen. Also, as I have seen this response waaay to many times, no the hold lock is not on and there is no lock icon on the screen. The hold switch works fine, with the exception that it acts like the hold switch is enabled even if the icon is not visible.

Thanks,

Scott

EDIT: Sorry Kiril, I know this isn't an answer, but it was too long to post as a comment.

by

Greetings, Scott

It's very unfortunate that you have the same problem. My research did not get me any results, but i have not given up yet. I am looking for broken ipod/board for parts, and i will solve this problem somehow.

Regards

P.S. Have you tried cleaning the board with alcohol and check the cables?

by

Kiril, the image just posted shows a red square with a component in it. Which component is missing?

by

Kiril, I have tried isopropyl (99%) alcohol and, using a q-tip, rubbed the entire logic board and clickwheel. No such luck. I have taken the thing apart so many times checking cables, etc., that I am sure the issues lies in the logic board somewhere. I have come to the conclusion that the clickwheel is still on "hold" even with the switch off and the icon not visible. I have read somewhere that the circuitry for the LCD and the clickwheel reside in different spots, so while the icon is not visible, the correct logic is not getting to the clickwheel. I wanted to meter out the component attached to the clickwheel ribbon cable and make sure voltage was getting to that IC or at the very least, to the connector for that ribbon cable on the logic board. I will have to take it apart again to determine the component and hopefully find a pinout schematic for it. While it is apart, I will take a picture of the logic board you showed so we can see if there is in fact anything missing from yours.

by

EDIT: Now that I think about it, the problem can't be just with the clickwheel because the play/next/back button aren't working either. It's been a while, but I thought that even if you were in the main menu, if you hit play, it would start playing music. At least that is what it does using the remote. I don't think the hold lock work-arounds will work either (tin foil across switch), since the hold state is getting to the logic board and displaying correct state on screen.

by

Show 1 more comment

Add a comment