Mid 2010 Model A1278 / 2.4 or 2.66 GHz Core 2 Duo processor

694 Questions View all

Can't find any networks

For five days now I haven't been able to connect to any networks at all. My airport is on, it just can't find any networks, none show up. Not my own, not my neighbors. I've done all the normal things to make it work, I even checked my router. My phone and every other device can connect, so it's just wrong with my MacBook Pro. I really don't know what else to do. I trouble shooted my entire computer, I did the advance setting checks. I'm not well betced with computers so if anyone can helper me know.

Thanks

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment
Deck the Halls
With tools and Fix Kits

2 Answers

Chosen Solution

Sounds like the AirPorts transceiver has given up the ghost or you got the AirPort board wet and the antenna connections are corroded.

Sadly this is a very big job as you need to take almost the complete system apart to get to the AirPort. Here's the IFIXIT guide for you to review: MacBook Pro 13" Unibody Mid 2010 AirPort Card Replacement.

I would locate an Apple authorized service center or Apple Store near you and let them deal with this repair.

Was this answer helpful?

Score 1

Comments:

Wow thanks so much!

by

If this answer answered your question please remember to rate (score) and mark it accepted.

by

Add a comment

Did this work for you? This wifi problem is excactly what my 13" MacBook Pro (2010) is currently plagued with. The OS is recognizing the network card so I was hoping it to be a software problem. Mahalo. @robertspina21

Was this answer helpful?

Score 0

Comments:

There are two sides to the card: The digital side and the analog side (radio part).

What can happen here is the radio side can have problems so the card still looks good but doesn't work.

Try this press the Right side Option & Shift keys and pull down the WiFi icon on the menu at the sometime. Do you see the signal levels? If not your card is bad, if you do its possible the antenna lead is broken.

by

Add a comment

Add your answer

robertspina21 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 223