Model A1297 Unibody: Early 2009, Mid 2009, Mid 2010, Early 2011 & Late 2011

455 Questions View all

Getting a Crucial M500 SSD working in Early 2011 17"?

I recently bought a 960Gb Crucial M500 SSD to put in my Early 2011 17" Macbook Pro.

The Finder can see the drive when it is in an external USB enclosure, but not when it is in the internal drive bay. From what I can see from a fairly thorough Google around, the problem is that the speed of the drive means the internal SATA hardware struggles. I've tried a different SATA cable (from an older Macbook) and that made no difference. I haven't resorted to some of the more exotic suggestions like wrapping the cable in tinfoil.

There are replacement hard drive cables listed in the store here:

MacBook Pro 17" Unibody (Early 2011) Hard Drive Cable

I'd happily buy one if I knew it would solve the problem, but it's an expensive gamble if it's going to be no better than the original cable.

Anybody got any experience with this? Thanks!

MacBook Pro 17" Unibody (Early 2011) Hard Drive Cable Image
Answered! View the answer I have this problem too

Is this a good question?

Score 0


Do you already know how to upgrade firmware to an SSD/make an SSD as a bootable drive in Mac OS X?


Max - You really need to create you own question here with your details. And, yes one can make the SSD a bootable disk.


Add a comment

2 Answers

Chosen Solution

First your system has a SATA III (6.0 Gb/s) I/O port so any drive that is SATA III should work here.

With that said there is a small wrinkle here. You'll note this drive also can work with a SATA II (3.0Gb/s) system "(SATA 3GB/s compatible)". That means it senses the I/O speed and auto sets to the correct data rate. There have been issues with some systems unable to handle the auto sense services and needed a firmware upgrade.

I would start by making sure the systems firmware is upto date. Follow this Apple TN: EFI and SMC firmware updates for Intel-based Macs I would also check with Crucial on any firmware updates for their SSD.

Let us know how it goes!

Was this answer helpful?

Score 1


The firmware on the Macbook is up to date. I tried updating the firmware on the SSD, but the installer just says "no eligible SSD found" which I hope means that the SSD firmware is up to date, rather than some problem with the installer recognising it.

I'm not sure if there could be something else here that I'm missing?


I think you need to speak with Crucial to see what they say here first. Sure it could be the SATA cable but this series hasn't had a bad run like others have. I would see if a different SSD worked here. Try to find a fixed I/O speed model (SATA III) or one that you can manually set.


OK, I've spoken to Crucial. Their guy on the phone was very friendly and trying his best to be helpful but this problem was something that they haven't come across before. He reckons that it's the SATA cable that is the problem, but that's based on what he read on Crucial's own forum.

It looks, unfortunately, like I'm back to square one...


mmm... Do you think you damaged the cable in the process of replacing the SSD? Then I would replace it.


It's a possibility, but the same cable is working fine with a standard hard disc so I doubt it's entirely broken. I also tried a cable from another machine, with identical results...


Show 9 more comments

Add a comment

Dan, it is a question. I'm trying to find out more from Stuart. Please understand my question is a probing one and not something I'm trying to ask Stuart for help.

At the same time thanks for taking the time to read and respond to so many of these posts. This is definitely one of the most active forums I've seen of late.

Okay then back to helping, Stuart. I've been able to get a like drive with different non-fixed SATA interfaces to work:

It did take me a while and I would have to review some notes and get back to you with a step-by-step. My original question that Dan seemed to miss was I'm asking if you know how to make the SSD recognized by the OS as your boot up drive and update it's firmware from within the Mac. This requires you to do a bit of coding if I can remember correctly and fixed any issue of recognizing/not recognizing.

On the Mac that's able to read it. What does it say for your SSD firmware in Apple>About This Mac>System Report>SATA>Select Crucial Disk>Revision.

From a quick google search it shows it should be at: MU05?

These folks have had success to:

I will try and review my notes about how to upgrade the firmware in a Mac. It may have been different for my 17" as I replaced my SuperDrive with another SSD. That one was from Crucial as well: Crucial M4 512GB 2.5" SATA III SSD. In the mean time, let me know what you find for my answers above.

Was this answer helpful?

Score 0


Sorry Max, Sometimes its hard to tell what people are doing.


Add a comment

Add your answer

Stuart Hogg will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 5

Past 30 Days: 13

All Time: 579