Mid 2009 Model A1278 / 2.26 or 2.53 GHz Core 2 Duo processor EMC 2326

786 Questions View all

Battery replaced and still doesnt work.

Hi all,

I’ve been a long time reader but I haven’t been able to fix my issue and its been nearly 18 months, so I need your advice as to what to do.

One day I was using my laptop (Macbook Pro Unibody Mid 2009 model) and realised that my battery was losing battery but it was plugged into the AC. Eventually my battery died so I assumed my charger had short-circuited. I used a new charger, and although it turn on my fear worsened when I realised that even with a new charger that it still said no battery available. Also the sidelights, which indicate the status of my battery, will no longer flash at all and the light on my magsafe is always green. So up to this point, my charger stopped working, and what looked like my battery had stopped working. I tried everything to resettling my PRAM and SMU to removing the battery and holding down the power button then restoring the battery. Nothing. I then had no choice but to order a new battery, which cost me £70. To increase my problem, a new battery didn’t work. I don’t remember resetting any settings once I placed the new battery in. I am now selling the battery if anyone wants it when I realised it wasn’t the problem. So then I thought, maybe the magsafe connector is the problem. But like I said previously, my computer still works when plugged in to the AC so therefore it isn’t the charger or the battery as both had been replaced, and it can’t be the logic board as my computer has been working for the last 18 months. I then did an Apple hardware Test and it came back with the code for no battery detected, even with my new battery placed inside. So this must mean that the connection between my battery and my logic board is somehow damaged. Am I right? Does anyone have any insight into how I can fix this or any place in the UK, which can fix logic boards and wont just tell me to replace it? I have a perfectly working mac when it runs off AC, and although it runs on half its CPU usage because it can’t detect a battery I have since gotten round that. I need help, and I have no idea what to do. If anyone helps me get my mac up and running I will buy you a beer or cold beverage if I’m ever in your part of the world/country.

Regards,

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

3 Answers

Most Helpful Answer

I think you have managed to discover the root issue here. While I can understand your frustration your indeed have a logic board issue.

You see, the logic board has different sections that do different things. In this case the area of the logic board that controls the charging of your battery has become damaged.

What I have noticed is in dry climates static can damage the battery charging logic when the discharge hits the MagSafe contacts of the system. This happens when people slide in and out of a cloth sleeves or case the friction causes a static discharge. The parts that get damaged is the switching MOSFETs and/or the comparator logic.

OK, what to do here. Install this little gem of an app: coconutBattery with it you should see the battery is not getting charged and the little charge that is left in the battery will be visible.

Let us know what you find.

Was this answer helpful?

Score 1

Comments:

Hi, it comes up with nothing....

Current Charge 0

maximum Charge 0

Design capacity 0

Manufactrue date Unknown

Loadcycles 0

OSX Battery status Unknown

Battery state Discharging

When i clck battery details same thing,

Battery failure None

Power Adapter: No Adapter found

The only thing i can mention is when i hold option and click onto the battery with the X on it, it does come up as Condition: Normal.

So im stumped.. Hope this helps

by

SMC is not working, this is also not good ;-{ The tool is telling you directly what SMC is seeing. As this point the you have zapped the both the MOSFETs and the comparator logic (which is part of the SMC logic).

by

This is going to take some effort to fix. Unless you have the skills to work with SMT components I would recommend you bring this into an Apple Store or authorized Apple services center.

by

Add a comment

I'd double check the battery Indicator Light (BIL) circuitry. Could be the reason why the battery is not charging. This board enter in relation with the charging system.

Was this answer helpful?

Score 1

Comments:

I've tried replacing the MagSafe DC-In board, but it was useless. I've also run "Apple Hardware Test" (form the installation CD which came with my laptop), and it has founded no problems in the Logic Board.

I've run out of ideas, don't know what else I can do!

I'm not sure what the BIL circuitry is... Could you tell me how to locate it in my laptop?

Thanks!

by

Add a comment

The same thing has just happened to me! But with a Macbook pro mid 2010, which uses the similar battery model. I've also bought a battery for my laptop (instead of a 77,5Wh - 2010 battery, I had to buy a 73Wh 2009 model, which is compatible with my laptop)

My old battery started failing, and this is what I get with coconutBattery:

- Current Charge 0 mAh (0%)

- Maximum charge 79 mAh

- Design capacity: 1,1% out of 6900 mAh

The battery is not charging, but in "Battery details" I read "Power adapter: 85 watts". So it DOES detect the power adapter, but is no longer charging (maybe because of its ridiculously small maximum charge number?).

However, when I replace it with the new 73Wh battery this is what I get:

- Current Charge 4352 mAh (59,1%)

- Maximum charge 7368 mAh

- Design capacity 6500 mAh (>100%)

Till that point, everything seems ok but... The battery is not charging! I can't disconnect the power adaptar because the laptop turns off as if no battery were connected. In addition, in "Battery details" it says "Power adapter: No Adapter found". So, this time, it DOESN'T detect the power adapter! (and that's the reason why the battery is not being charged).

Why?! I though it was also a logic board problem, but it detects the power adaptar when I connect my old, faulty battery... Does this happen also to you?

Thanks!

Update

Hi!

I've also tried to reset the SMC, but I'm not sure if I'm doing it properly... These are the steps Apple says I should follow:

"Shut down the computer.

1. Plug in the MagSafe power adapter to a power source, connecting it to the Mac if its not already connected.

2. On the built-in keyboard, press the (left side) Shift-Control-Option keys and the power button at the same time.

3. Release all the keys and the power button at the same time.

4. Press the power button to turn on the computer.

Note: The LED on the MagSafe power adapter may change states or temporarily turn off when you reset the SMC."

However, when I plug in the Magsafe power adapter to my laptop, it goes green and my lapton starts running as if I had pressed the power button. So, what I do is: 1. Shut down the laptop, 2. Press the 4 keys indicated, 4. Release all the keys and press the power button.

When I do so, there's no change in the LED light on the Magsafe cable.

I should also have mentioned that, even with the new battery, the 5 lights of the battery indicator are flashing when I press the button. I know that means that the battery needs to be replaced, but, as I said previously, it is new and has no more than 1 cycle, full capacity (even that Coconutbattery says it has "poor" health).

And I think I am in a "normal" area, the same place I've been using my laptop during more than 4 years! I don't have a case either (I just use a laptop-backpack when I need to carry the laptop with me).

Thanks!

Was this answer helpful?

Score 0

Comments:

Try resetting the SMC. follow this Apple TN: Intel-based Macs: Resetting the System Management Controller (SMC). When I replace a battery I often have to do this to get everything to work correctly. Even still I often encounter burnt FET & comparator logic. Are you in a static prone area and do you have a case that rubs against the MagSafe connector?

by

Hi, I've updated my answer in order to reply your question :)

by

Add a comment

Add your answer

Siam786 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 6

All Time: 865