Why is my Kindle stuck in a reboot loop?

So, my Kindle is essentially stuck in a reboot loop, but not one that indicates a software glitch. I've rarely used it since I got it in 2012, and this is the second time it's happened. The first time I was able to leave it on the charger for a while and it was fixed, but this time, it's no use.

It will flash the Kindle Fire orange and white logo a few times, then turn on as usual. But then, it freezes and shuts off, then reboots itself. I've tried hard resetting, as well as disconnecting and reconnecting the battery, but nothing has worked.

I can't reset the Kindle to factory defaults in the device settings because it won't stay on long enough, and it won't be recognized as a USB device on my computer because it won't stay on long enough to connect.

I suspect it's a battery issue because one time I was able to get it to display the low battery symbol when plugged in, but on the next reboot it showed 86% battery.

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment