Model A1311 / Mid 2011 / 2.5 & 2.7 GHz Core i5 or 2.8 GHz Core i7 Processor

262 Questions View all

LCD screen black when powering on

I just completed an ssd installation in my mid-2011 21.5'' iMac. When it powers on I get "the tone" however my LCD screen remains black. I opened up the back and checked the diagnostic LEDs: lights 1, 2, and 3 are lit and steady, however the fourth does not light up. I looked up what this means and took the LCD screen back off, replugged all the connections but it remained as before. Additionally, a few seconds (~10) after turning on the fans turn on and go to max. I'm not sure if that's related in any way or if that's just something else.

The installation of the ssd was prolonged after I had serious trouble getting the logic board back in. As it stands it's all "in place" but it's not perfect. I don't think I damaged or otherwise messed up the logic board, but I was a little rough with it, and spent a lot of time (man)handling it.

Anyway I'm not really sure what to do about it. 3/4 LED lights on makes me think I didn't accidentally break my logic board or something horrible, but I can't think of what could be causing the LCD screen of all things to be malfunctioning. I'm going to be taking it to a repair shop, so whatever I can tell them to guide them the better.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Sounds like you may have something caught.

While the board is a bit tricky to slide in, it should seat with out any resistance - enough to slide side to side and with slight pressure sit on the stand offs (offsetting the springiness of the wires).

At this point I think you'll need to take it out again and carefully look for damage to the board or the wires.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Alexander H will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 149