Released October 24, 2011 / 2.2, 2.4, or 2.5 GHz Quad-core Intel Core i7 Processor

252 Questions View all

Why won't Dual Drive (1 TB Seagate SSHD) format?

I purchased the dual drive optical bay converter with a 1TB SSHD. All the hardware went into the laptop no problem. I am having an issue formatting the SSHD in the optical bay. I am using Disk Utility on Mac OS X 10.9.4. The drive easily formats to MSDOS and ExFAT formats, but fails when formatting to any Apple formatting system. What am I missing? I tried to use the Seagate drive software, but it is Windows-only. I've also tried partitioning over the current partition. No luck. I can partition to free space with no issue. Just not able to create an Apple Extended format partition.

Disk utility error:

Block Image

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Chosen Solution

Try deleting all of the partitions and try again.

Can you give us the model number of the Seagate drive you got.

Was this answer helpful?

Score 1

Comments:

I have tried deleting all of the partitions to free space but that doesn't work either. Using the erase part of disk utility only works when erasing to MSDOS or ExFAT formats. Here is the link to the drive I bought:

1 TB SSD Hybrid 2.5" Hard Drive

It says that it should be compatible with the model MBP I have.

by

For clarification, I think the seagate model number is "ST1000LM014" (visible in the close up image on the product page).

by

This model has an issue with the higher speed SATA HD or SSD in the dual carrier. Here's a note on the issue from OWC Data doubler. The seagate drive you have is a SATA III (6.0Gb/s) while this drive can match to SATA I or SATA II I/O speeds the system is telling the HD it can run at SATA III so you get into a bit of a mess. I am surprised you can create FAT32 or ExFAT partitions with this drive. The older version of this drive could work here as it's I/O is SATA II. OK, what to do? I would try setting up the drive externally to verify things. If it worked that way that proves the issue. The other option here is to swap the drives around if your Apple drive is SATA II, more likely it's SATA III so while it may appear to work you could encounter corruptions.

by

Add a comment

Add your answer

Alex will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 6

Past 30 Days: 19

All Time: 1,924