Model A1418 / Late 2013 / 2.7 & 2.9 GHz Core i5 or 3.1 GHz Core i7 Processor

66 Questions View all

Kingston HyperX SSD issue on iMac

Hi,

I successfully installed KingSton HyperX 480 SSD on my 21.5 iMac late 2013, and work perfectly for 3 months.

The one day after updating iTunes and restarting the iMac got flashing question mark folder icon, I tried many ways but iMac won't read SSD at all, even after removing SSD and install it on Dell PC won't read it.

- Now, all my data gone - is it? - Is there any solution for this issue to get back my data?

- Im a fried too much to buy new one and died again! is this possible ?

- Final, Is Kingston HyperX 480 very Compatible with iMac?

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

How did you install this SSD? Did you replace the internal HD or are you using it externally via USB3 or Thunderbolt connection.

by

YES, Replace internal HD by myself.

by

Add a comment

1 Answer

Chosen Solution

I would talk with Kingston here as your drive should have worked without any problems here.

As to saving your data you will need a second Mac connected via Ethernet or ThunderBolt (USB2 is slow) back to back so your system can be started up in Target mode. Here's how to do to it: OS X Mavericks: Transfer files between two computers using target disk mode,

Then you'll need to try Disk Utility to see if you can repair it. If that fails your options here are limited.

Was this answer helpful?

Score 1
Add a comment

Add your answer

ADNAN MARGELANI will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 8

All Time: 442