Mid 2009 Model A1278 / 2.26 or 2.53 GHz Core 2 Duo processor EMC 2326

793 Questions View all

Wifi no hardware installed but bluetooth and camera both work

Hello,

I've literally scoured the internet for solutions to this issue and have tried them all fruitlessly. Here's to hoping someone here has a better idea as to what's going on with my MBP.

Essentially, I have a grey icon with an X over it where the wi-fi icon should be, which when clicked, reads "wifi: no hardware installed." The other functions of the card and cable, bluetooth and the camera, perform correctly.

I have tried 3 different screen assemblies with the same effect. The logic board was recently replaced by Apple and is brand new. The issue persisted before and after the logic board replacement.

So, why would this be happening? Is it software related? You would think that with all the different hardware and the issue still persisting that it couldn't be the hardware.

I have tried several reinstalls of os x including 10.8, 10.9, and 10.10; the issue persists. I have tried accessing wifi from usb install drives and the recovery partition. I have tried all of the usual pram, smc resets, deleted plist files, held the power button down for elongated times during startup, etc.

I cannot access the apple hardware test (AHT) for whatever reason. I have taken it into the Apple Store and they have run the AHT and it has shown that the wifi is not working properly.

I'm convinced it's nothing in the screen assembly. Any help would be fantastic and greatly appreciated.

Thanks!

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

You said that Apple did the repair. Was this a "flat rate repair".

by

Add a comment

1 Answer

You might have installed software that has permanently damaged something. It's happened to my computer once. I had to 'completely erase the whole computer. A system file might have been corrupted. Take it to a licensed retailer, like Apple, and ask to see if anything like that could happen. Or, it just might be a hardware problem.

Was this answer helpful?

Score 0

Comments:

Thanks for the response; it's appreciated. Did erasing and reinstalling solve the issue for you? And what type of erasing are we talking about? Military? I have tried erasing and formatting with disk utility then reinstalling the os and the issue persists.

by

It worked, but only temporarily. It was just regular user erasing. If it keeps persisting, it might be a hardware problem.

by

Add a comment

Add your answer

Chris Farley will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 4

All Time: 931