Model A1286. Released February 2011 / 2.0, 2.2, or 2.3 GHz Quad-core Intel Core i7 Processor

368 Questions View all

weird issue with battery

I believe there is something wrong with the Logic Board - it will work fine as long as there is no battery connected!

If you connect a battery (I have tried a dead one and a brand new one that I just bought and tested in another mac) and it will work for about 30 minutes, before just shutting off and not turning back on. Unplug the battery, wait a few hours and it will work again without a battery, on the charger only.

Is there something wrong i can check with the circuits that control the battery charging system?

edit: after the 2 hour waiting period, after it shuts down, it will work normally with the battery for another 30mins or so,and will repeat those stages.

Also during the 2 hours it will not work after shutting down, the battery indicator doesn't show a battery installed, and the mag-safe indicator is a faint green, turning bright green after the 2 hours, when it is able to turn on again.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

any other suggestions are welcome!!!

by

after the last shutdown an error was reported, called a sleep wake failure. i have reset the smc, and installed coconut, which reports the batter to be working.

by

Can you post an image of coconut so we can see.

by

Add a comment

1 Answer

Chosen Solution

Did you try resetting the SMC yet? Follow this Apple TN: Intel-based Macs - Resetting the System Management Controller (SMC).

I would also install this gem of a utility: coconutBattery

See what happens afterwards and take a screenshot of coconutBattery for us to see whats happening.

Was this answer helpful?

Score 1
Add a comment

Add your answer

brad will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 121