Skip to main content

Fix Your Stuff

Right to Repair

Parts & Tools

Can I run OS X 10.7 on my iMac?

Can i run OS X 10.7 on my IMac 4,1?

Answered! View the answer I have this problem too

Is this a good question?

Score 2
Add a comment

Nintendo Switch Kits

A quick fix to get back in the game

Shop Switch Kits

Nintendo Switch Kits

A quick fix to get back in the game

Shop Switch Kits

1 Answer

Chosen Solution

The highest system a G5 will take is 10.5.8. The iMac 4,1 hasn't been used since the G3 machines. Please give us the serial number from the bottom of your stand.

Was this answer helpful?

Score 1
Add a comment

Add your answer

hamza will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 515