The Samsung Galaxy Nexus is part of Google's NEXUS lineup of flagship devices. It has an HD Super AMOLED display, curved display, and Android version 4.0 Ice Cream Sandwich.

52 Questions View all

Galaxy Nexus does not start at all?

Hello my Ifixit friends! A customer brought me a Galaxy Nexus (I9250) with a rather strange problem. He had problems charging his phone over the past month or so, saying he had to hold the cable in a very specific way for it to take any charge. Then, it stopped taking any charge at all.

I assumed the problem was the charging dock, so I changed it out to a new one and attempted to charge it. No luck. The battery looks fine, however I do not have a new one to try. (I've ordered one now, should come soon..)

I've checked the motherboard for any signs of water damage but it looks beautiful. Despite that, I cleaned it with some Isopropyl and a soft brush. Any ideas besides the battery? I was thinking about changing out the screen, to see if the screen could in some way be damaged. (Customer claims he's never dropped the phone, and when I look around the edges it looks to be a true statement.)

I'm at a loss except for possibly the battery, which wouldn't make sense from the information I've received from the customer...

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

Hey guys, sorry I haven't replied lately. Been really busy!

Sadly I never got the phone working, I tried changing out virtually everything in the phone. From the dock to the battery to the screen itself. No life what so ever.

The weird part is, just a few days ago another customer came in with the EXACT same problem. I couldn't get that one working either. They must have some built in life time, wouldn't surprise me...

by

Add a comment

1 Answer

Most Helpful Answer

Hello Alexander,

I am a repair tech and we recently had a lot of the Galaxy Nexus 4s come in, I saw that when the battery died all the way they went into a "deep sleep" mode. I would hold down the power and volume down button and plug it into the charger while still holding the buttons down. If that doesn't work I would hold the middle of the volume buttons and power button and plug it in. If none of that works leave it on the charger for around an hour or two and then try the steps above!

Hope this helps!!

Was this answer helpful?

Score 1

Comments:

Hey Donley, thanks a lot for your reply! I tried doing as you said to no luck. I wonder if the battery in it is completely fried. Waiting on a reserve battery, I'll update the more I find out. :)

by

Glad to see you aren't giving up hope ;) Also if you need anymore parts for that you should check out idoctormt on ebay! We have a BOATLOAD of Nexus 4 parts.

by

Add a comment

Add your answer

Alexander will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 6

Past 30 Days: 30

All Time: 875