Model A1311 / Mid 2011 / 2.5 & 2.7 GHz Core i5 or 2.8 GHz Core i7 Processor

268 Questions View all

Fan not working on second HD in iMac?

Hi. My iMac is a i5 model, I have a second hard drive installed and installed MS Windows 8.1 with bootcamp.

When i use Windows the fan will not go on. I installed Speedfan and it shows the video card processor and hard drive, but no fan. Is there any way can i make the fan go on on the second HD of windows.

Thanks

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Vito,

There is a a dedicated fan for your main hard drive and also a fan for the optical drive. In both cases these fans are controlled via SMC services in your system. The SMC services are not accessible via MS windows but accessable via Apples OS-X.

This gets into the API's and how they are accessed via the OS. If you give this application a try running under OS-X Temperature Gauge Pro you will see the fan & thermal sensors, unlike Speedfan which can't access the OS-X API's.

Was this answer helpful?

Score 2

Comments:

Temperature Gauge is ox appl. the speedfan i install is for windows, i can see any fan on windows when i run speed fan? that i have installed on the 2hard drive. with bootcamp no os.

by

Correct Temperature Gauge is a OS-X-application and needs to run with OS-X. Speedfan can't access the needed OS API's to see the fans. SMART services are within the hard drive and don't have access to the system hardware.

by

ok, i try and see if works, like u said … thanks

by

Add a comment

Add your answer

vitodeluca will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 80