Skip to main content

Model A1312 / Mid 2011 / 2.7 & 3.1 GHz Core i5 or 3.4 GHz Core i7 Processor, ID iMac12,2

532 Questions View all

SSD as second drive not detected?

I just bought dual harddrive kit for iMac 27" mid 2011. I am planning to make fusion drive with SSD 120GB Corsair GTX.

I follow the instruction from here and also watch the video. All done as the instruction.

Problem is when I turn on my iMac and go to Disk Utility, I cannot fine my new SSD drive.

I also trying to boot from USB Maverick installation disk and do the Terminal - diskutil list but the new SSD drive is not detected.

What could be wrong? Could be the sata cable damage?

I tried the SSD on my windows computer and it is working. The bios detect it.

Thank you very much.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

Android Fix Kits

A new screen or battery is one kit away.

Shop Now

Android Fix Kits

A new screen or battery is one kit away.

Shop Now

1 Answer

Hello,

Maybe the SSD needs an update, you can see here

Was this answer helpful?

Score 0

Comments:

I gues the problem is from the SATA cable. I tried using the sata cable that connect to the first HD (1TB) and plug it into SSD and the SSD working normal.

I notice that the SATA from iFixit -- the power cable only have 4 wire, but the original one has 6 wire. Both that connect to Optical drive also have 6 wire.

Maybe the iMac must have 6 wire for the power cable. Let me ask iFixit about this cable.

Thank you very much for the respond Sir... Really appreciate it.

by

The cable is damage and iFixit send me a replacement. Now it's done and working perfectly.

Thankyou iFixit for fast response and sending the replacement cable.

by

Add a comment

Add your answer

asic99 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 512