iPod Nano 6th Generation

Model No. A1366 / 8 or 16 GB capacity

147 Questions View all

White screen after repair

I had a working cracked screen and wanted to replace it. I bought a new assembly replacement on ebay. I installed the screen and received a 75% white screen with a pink/grey band along the left side with an irregular border. I figured something was wrong with the assembly I purchased.

I then replaced the old broken screen which had just been working and now that screen is all white. I tried restoring the device and doing manual restore procedure by holding the volume - key and power. Nothing happened other than the screen flashing a few times.

Any suggestions for how to manage a white screen? I was going to buy another replacement assembly but am worried that the same thing will happen. I'm still able to connect and restore fine through my computer. Thanks for the help.

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

I got a new screen and it worked fine.

by Boback

Add a comment

1 Answer

Look at the connectors, make sure they are not damaged, if there is some damage, you would need to solder a new connector on. if none of this solve your issue, then send me a close up picture of the Logic board, so i can see if there are any fuses missing.

Update

The pictures you uploaded are not very clear, can you take a clear close up of the logic board itself. Please take out the connectors before taking the picture. Please use this guide Adding images to an existing question to upload pictures

Mentioned Items

Was this answer helpful?

Score 0

Comments:

What fuses are you talking about? There are no fuses. Looking at your other responses you seem to be just entertaining yourself with these replies.

by Boback

Add a comment

Add your answer

Boback will be eternally grateful.

View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 5

All Time: 347