MacBook Pro 15" Retina Display Mid 2012

2.3GHz, 2.6GHz, or 2.7GHz quad-core Intel Core i7 processor (Turbo Boost up to 3.7GHz) with 6MB shared L3 cache.

180 Questions View all

Replaced MagSafe 2 DC-in board, laptop still not charging. What now?

I followed the instructions fully and now my laptop will not charge. I followed apple's instructions on how perform a SMC reset and a NVRAM/PRAM reset, but my laptop is still not charging. I also purchased a brand new charger from the apple store.

Is there a way to re-sync the logic board and the MagSafe 2 DC in board that I'm missing?

Could it be that the DC in board that I purchased is faulty?

Or is it that the logic board is faulty?

My laptop still turns on and runs but I only have 58% of battery life left.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Yes - could be either of those things. Why did you feel the need to replace the DC in board in the first place? Spill? Fall?

Was this answer helpful?

Score 1


My charger was frayed and it would get warm. Sometimes I would have to play with the cord to get it to charge. One day I was playing with the court when I heard a popping sound near the MagSafe 2 DC-in Board and I smelled the burnt electronics oder as well. The light on the MagSafe 2 charger went out as well. I thought I may have fried my charger so I purchased a brand-new $80 charger from the Apple Store but my laptop would not charge. So I went through the common troubleshooting procedures and finally decided to change my DC–in board. When I opened up the MacBook I discovered that the P7 transistor on the old DC-in bold board was burnt out, as indicated by the black soot around it. I purchased a brand-new board from iFixit but I noticed that the wire colors were different than the wires on my original board. My original board had all-black wires while the board from iFixit has three black wires and two gray.

by majesticdre

What I've decided to is was downgrade my laptop to the original OS which was OS X 10.8 mountain lion and see if the reason why the iFixIt DC-in board doesn't work is related to firmware or the OS X operating. I'm thinking that when I upgraded to Mavericks my firmware may have upgraded the original DC-in board, but most likely not, I'm just desperate just trying everything, this is a shot in the dark.

by majesticdre

I took it Apple, they couldn't do the repair at the store do they sent it to their repair depot for repair at a flat rate. Turns out it was the DC in board and the Logic board. The cost was very very reasonable for what they had to repair/replace.

by majesticdre

Thanks for taking the time to return and let us all know the true problem and it's solution

by machead3

Add a comment

Add your answer

majesticdre will be eternally grateful.

View Statistics:

Past 24 Hours: 0

Past 7 Days: 4

Past 30 Days: 8

All Time: 266