The PowerMac G5 is a desktop computer first produced in 2003 by the Apple Corporation. This guide will review the repair process of an Apple PowerMac G5 model number A1047 EMC 2061 from 2004. It was discontinued in 2006 as part of the Intel switch first to developers then consumers.

221 Questions View all

"post/12288/0" what's this referring to?

I get error: post/1228/0 after running the Apple hardware test.

I've tried re-seating memory, removing graphics card, resetting pram, etc.

The machine doesn't get past the Apple logo before it shuts down.

And I've just replaced the duff PSU with an identical (working) PSU. Is that the problem?

Answered! View the answer I have this problem too

Is this a good question?

Score 0


What OS (OS's) are you using (if you are using something other than OS-X and which release)? Was the system flaky before you encountered this error?


What happens when you remove the RAM and disconnect the HD internally? Any difference?


Hi Dan,

Thanks for your input.

I'm using OS 10.5.8, which is the the last pre-Intel OS you can use on the Power Mac G5. And I'm not sure what you mean by "flaky". I get no hints of anything springing into life, if that's what you mean.

I removed RAM and the HD connections. All I got was a flashing "?" and folder looking for start-up instructions. Tried a G5 install disk and it wasn't recognised.

Reassembled and again nothing past the Grey screen and Apple logo and then it quit. As before!


Flaky - erratic running, sometimes its OK other times not or odd issues happening unexpectedly.


Add a comment
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

1 Answer

Chosen Solution

OK, thats a good sign. So we know the issue is not the logic board but either the RAM or the HD as you wouldn't get the question mark if the logic board has an issue.

Now leave the HD unplugged add in the RAM one bank at a time make sure you are using a matched pair. If you encounter a problem with one set try the other/s. Are you still getting to the flashing Q mark after each set has been swapped out (tested)?

Do you have an external FireWire HD or still have the CD/DVD that came with your system (grey disks) or have the Apple logo'ed retail versions? If you do try starting the system with one of them with one set of RAM in place. Are you able to get to the installer screen? Or in the case of a HD the desktop?

Was this answer helpful?

Score 2


Hi Dan. I unplugged the HD. Tried all of my three pairs of ram in each available slot, one pair at a time and got the flashing "?" each time.

Then did the same to the ram with my original grey start-up disk 1 loaded. Each time the disk was recognized and the Apple logo appeared on screen. Two seconds later the machine shut down. It can't be the HD then! What next?


Just so we're clear here the system went cold on you correct? no errors, just shut down. Carefully pull off the Power Mac G5 Processor and Cooling Unit Replacement so you can check to see if you have any damage from the coolant leaking onto the logic board. Make sure you follow good ESD precautions.


Add a comment

Add your answer

43Gruff will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 86