Fifth generation of iPhone. Repair of this device is straightforward, and requires screwdrivers, prying tools, and patience. GSM/CDMA / 16, 32, or 64 GB / Black or White.

2854 Questions View all

no GPS reception after opening the phone

Hello,

I have my iPhone 4s a couple of years now.

It has been jailbroken as soon as i could with the iOS on it and I never had any problems with the phone.

A couple of months ago the battery became worse and worse and i replace it. Went off without a hitch and it worked fine with the new battery.

A few days ago I got into bad weather an a lot of raindrops splashed onto the phone. That never was a problem before so I thought nothing of it, but a few hours later when I tried calling someone I realized that the earpiece did not work anymore and I could not hear the person I called. When I switched to loudspeaker it worked, but I wanted to fix the earpiece.

So i opened up the phone and searched for water drops or signs of water and found none. I sucked air out of the front hole for the earpiece in order to get water out of it which I suspected inside, but at first that brought no change and the earpiece did not work.

I decided to power the phone off over night and let it dry (even though I did not find water or any signs of water inside the phone).

The next morning I switched on the phone and I was glad to see (or hear) that the earpiece worked.

So I was happy with myself and went to work, the phone did everything it should (good cell reception, wifi worked perfect and the 3G connection was fast).

What I realized later in the evening was that the GPS was extremely inacurate. (best case 65meters, worst case 1,6 kilometers). With that accuracy its my opinion that the GPS doesnt work at all and the Position is just determined by the cell towers in my proximity. So my GPS is completely broken now.

And now the bad part. There is no guide her on iFixit for any GPS problem. I cant fix my phone if I dont know which part to swap out or which connections to check or to clean.

Can someone help bring my GPS back? I use it daily and really need it. The phone is pretty useless to me without its GPS capabilities.

I need to know where the parts sit that are responsible for the GPS and I would appreciate any help.

I hope this little text is not too long, just wanted to have all relevant details in it.

Block Image

Block Image

Block Image

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

The GPS antenna is the top metal band on the frame, check the top screw is tightened securely and the gold contact pin is contacting the board properly. Also disconnect the battery to reset the clocks and power the phone back up again. It might help by starting over. These are the first things to look at.

Check the entire GPS/cellular diversity RF path by purposely disconnecting the lower antenna cable. If the cellular service is still working then there is unlikely that the top antenna path is broken. if the service is lost, then the failure is isolated to be there

Was this answer helpful?

Score 1

Comments:

Could you describe or show to me which gold contact pin you mean?

The screws are all secured and I hope that no emi shield or contact is missing.

So if I disconnect the lower antenna the reception should still be there?

by

I tested the phone with the cable to the lower antenna detached and the cell reception was still there. Now what?

With or without the lower antenna attached i get a good cell reception, also perfect wifi and everything else works fine except for the GPS.

Im searching for everything that could be missing for the GPS to work but so far I havent found something missing, broken or detached.

But the fact that there are absolutely no guides for GPS problems on iPhone 4s isnt helping. :(

by

If the cell is still working without the lower antenna, then the top antenna is unlikely to be faulty. Restore the phone and then disconnect the battery, start the phone over and try again. Also can you take HD pictures of the logic board? The entire portion below the SIM card slot.

by

I added some pictures of the phone and the lower portion of the logic board. Can you see enough or do you need another angle or more parts removed?

I was hoping to avoid restoring the phone, but if its necessary I'll do that. :(

What I allready did numerous times is disconnecting the battery and after connecting it again do a reset with the power button and the home button pressed for 5 seconds.

by

You can see 2 RF test connectors above LAT connector. The upper one J7_RF has a small black/green module right next to it, this is U17_RF, it separates GPS and cell signals. The smaller module right next it is U15_RF, a GPS amp. Then the GPS signal goes into the SAW bank inside the RF shield. I suspect the amp may be dead or not receiving on command. Also a complete software reinstall may solve the problem, it maybe a software issue anyway

by

Show 4 more comments

Add a comment

Add your answer

Andreas Kneller will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 21

All Time: 2,400