no battery found after installing harddrive

After I have installed a better hard drive I have problems with the battery of the MacBook Pro. It seems it is recharging, but the MacBook Pro doesn't seem to notice it is installed. After resetting something to detect the battery by holding the power on button for 30 seconds and after that plugin the power cord the laptop is fine. But after closing the laptop the problems reappear.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Chosen Solution

The problem may be with your system software since you changed hard drives. How did you set up the new hard drive? Just to check I would start up from the installation disk and go to Disk Utilities on the second page and repair the disk and then repair the permissions.

Was this answer helpful?

Score 0

Comments:

After installing my new hard drive I put my Snow Leopard DVD in my MacBook Pro and choose to format to mac file system. After that I installed Snow Leopard. When using TechTool Deluxe an error occurred with Volume Structure.

by

I used Disk Utilities that is installed on my hard drive to repair permissions and the disk. After that TechTool Deluxe found no problems with Volume Structure. But the battery not found error wasn't solved. After that I tried Disk Utilities on the Snow Leopard installation disk. The battery not found error still exists. Sometimes after doing a reset by holding the power on button for 5 seconds the drive is found and is recharging for about 15 minutes. After that the battery is not found. Other times the battery is not found immediately after calculating the time to have a full charged battery. Closing the lit does not always cause the problem.

by

Add a comment

Add your answer

isnuijen will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 1,236