0

Score

Avatar
Jakob
11

Asked

new built-in screen turns off

History

Hey guys!

After replacing my old lcd on my 2010 Macbook following the ifixit procedure i tried to restart the ddevice.the new screen shows the filevault password request. After entering it the apple startup logo appears, then little time later the little progression wheel is shown. Then the screen suddenly just turns off, as if, having started osx, it w as rejected. Trying to find out whether osx really starts has not been sucessful yet, i connected the device to an external screen but couldn't see anything. Nevertheless after the screen is switched off the macbook seems to be running, pressing volume or brightness keys even causes the well known clicking sounds.

Exchanging it again with the old one did not help, the screen still was black.

Can you help me with this issue? Don't know what to do next. .

Edited by: Jakob ( ) , machead3 ( )

I came accross the solution for the replacement problem while further checking similar behaviour description after startup on ifixit. It the lcd that I ordered first (TLN133AT09) could not be used by OSX, because it is not compatible to the operation system. The one I bought next was the same as the original one (B133EW04) and it worked flawlessly. Likewise LP133WX2 is also said to work for A1342, but I didn't dare to test it.

Jakob,

Add Comment Cancel

Post Answer

1

Score

Avatar
machead3
99k

Answered

Accepted Answer

PermalinkHistory

If you see nothing at all on an external display it is a GPU/VGC logic board problem.

If this answer is acceptable please remember to return and mark it.

Edited by: machead3 ( )

Add Comment Cancel

Add Your Answer

View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 49