Boots to Apple logo, can't access filesystem

My iTouch 4g was working just fine until two days ago. I hadn't installed any new Cydia packages, hadn't updated any (no updates were available), nothing had been changed. The device is running iOS 5.1.1

I had the following Cydia packages installed:

AppSync for iOS 5&6

CameraTweak

Double At

GlyphPatch

iFile

KillBackground

MxTube

NoSpot

Overachiever

PasswordPilot

RecoveryGuard

xCon

I believe the tweak RecoveryGuard is what is causing my current issue. This tweak makes the hardware fool iTunes into thinking it always has the latest version of iOS. This prevents the device from entering Recovery mode. I've been able to get my device to boot into Recovery mode, despite this tweak, but iTunes doesn't see that the device is connected. I also tried iTools, iRefone, ReiBoot, iFunBox and others and none would detect the device. The only apps that would detect the device are redsn0w and TinyUmbrella.

I attempted to restore the device using the Restore option in redsn0w but it didn't work. The device would seem to be preparing for the restoration but would boot up and show the Apple logo before redsn0w finished uploading data to it. I can't access the filesystem since none of the programs for that would detect the device, so I can't manually remove any Cydia packages or Sources and I can't SSH into the device either.

I've tried with the device booted (well, with the Apple logo still on-screen when it should show the GUI) and also with the device in Recovery mode, DFU mode and Pwned DFU mode.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Chosen Solution

If you have your SHSH blobs backed up, you can DFU to the backed up version without any problem. Install a clean copy of iOS and start over. If you don't have the SHSH for that version, A4 devices can still be cracked.

The DFU mode is entirely based on hardware, if it fails, try another computer. If everything fails, there is probably some problems with the hardware.

Was this answer helpful?

Score 1

Comments:

I do have the SHSH blobs saved. I don't have access to another computer so I will attempt to restore it using redsn0w again, but try with the other version of Windows I have installed on my laptop (dual-boot situation)

by

Well, not sure what I did but I finally managed to get my device to restore using redsn0w. I tried using different USB ports, as well as the aforementioned dual-boot operating system. It took several tries but redsn0w pulled through, as it always does. Thanks again Tom!

by

Add a comment

Add your answer

Sean Shaffer will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 123