Replaced HeatSink and Now Display Backlight Won't Turn On!

I swapped out the heatsink on my 15" MBP and everythong seemed to go fine. The instructions were clear and easy to follow. My computer had been shutting down immediately and was unusable. I did some research and it sounded like the heatsink was the problem. After reassembling the computer, when I started it up, there was a little PUFF OF SMOKE from the back left of the keyboard (above the "esc" key). And... the screen stayed black, no screen backlight came on.

The repair solved the problem of my computer constantly shutting down, but now I can only see my screen if I shine a bright light on it.

Does anyone know what could have happened? If the thermal compound was touching some little wire or something, could it have caused a short?

Also, how can I diagnose if the problem is a display inverter or the inverter cable?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

It seems the camera and inverter share a cable assy. My guess is that you have damaged this cable somehow and shorted something out. Unfortunately you may have damaged the logic board in the process.

Things to try.

  1. check the brown and yellow wires with a ohm meter to see if they have continuity end to end (I assume these are the inverter wires)
  2. check the same wires are not shorted - unplug from logic board and test between the yellow and brown wires
  3. check between the pins of the connector with this cable out and again with the cable in.
  4. check the inverter input is not shorted between the pins where the yellow and brown wires plug in with/without the cable in place

WARNING testing voltages requires you having system disassembled and ON at the same time so extreme care is required to avoid damage to you and the device. Not comfortable doing this? then DONT

If there are no shorts between pins, wires etc and each wire tests out end to end then the next step is to test the voltage on the INPUT of the inverter. best place to do this safely is on the logic board at the connector where the yellow/brown cable plugs in.

IMAGE

I don't know what the voltage will be but I assume something between 5 and 12VDC (iMacs use 12VDC) If it is present, do same test at other end of cable on INPUT to inverter. IF OK then it suggests the inverter is faulty however if there is no voltage from the logic board then the logic board has sustained damage. If there is voltage at the logic board but none at the inverter, cable is damaged (but this should be apparent from the resistance (ohm) tests earlier.)

Post back results.

Was this answer helpful?

Score 1

Comments:

I was hoping I could I rule out the logic board by reassembling the computer and attaching it to an external monitor. Would this work?

by

I tested the inverter cable for continuity and it is good. It also did not appear to be shorted, in that there was not continuity between any of the separate wires. Also, the yellow brown cables are for the isight camera, the red-yellow-blue-green wires go to the inverter cable.

I'm not really comfortable running the computer while disassembled without a little more input. Is it okay to run it with major components are unplugged? Like the monitor/temp sensors/fans/hard drive? If so, I'll give it a shot.

Thanks for your help with this!

by

thanks for clarifying the cable colours. I was presuming the inverter input was just a simple 2 wire supply and that they were duplicated to handle the current required.

The fault as described is the back light so if the system is reassembled, running with an ext monitor will confirm (mostly) there is no damage to logic board. However, you appear to have shorted something anf if you have damaged the supply circuit for the inverter power you are in trouble. (I assume it reside on the logic board)

You should NOT run the system with components like fans, lcd, sensors unplugged. You can probably power up OK with no HDD. Ideally you need to expose the inverter so you can measure the input voltage while having everything connected and safe so no shorts can occur.

by

I went ahead and ordered a new display inverter. My only concern is that I haven't found what caused the problem in the first place and I'd hate to fry the new one. But, I can't think of any other solution at this point- not feeling to brave about running the computer while it's all taken apart.

Thanks for the help, will update.

by

You may want to check the inverter output wires are not damaged. I have read a few posts now where replacing the inverter does not help with the reported symptom! There has to be a root cause. Perhaps there is a short on the output or one wire is shorted to the chassis..??

by

Show 2 more comments

Add a comment
Most Helpful Answer

From your description, you may have crimped a wire somewhere and shorted the inverter and thus the back light does not work any more.

First you need to establish what went up in smoke. If it's just a melted wire you may be ok if you resolve the short and repair the wire (replace or tape with good quality electrical tape)

If there is signs of damage to the main board then you are in trouble.

Check the cable for the inverter that comes off the logic board and goes up thru the hinge assy to the inverter board

refer THIS picture and THIS procedure for reference

HIH

Was this answer helpful?

Score 1

Comments:

My dilemma is that nothing looks burnt. So how can I diagnose the problem. Should I just order a display inverter for $70 and hope that fixes the problem?

by

You need to find what caused the smoke you described. No point spending money on an inverter just yet. Do you have volt meter?

by

I don't have a volt meter. I can probably get my hands on one though. Is there a way to test the inverter and/or the inverter cable?

Thanks so much for your help!

by

Add a comment

Add your answer

jonahwy will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 2,966