Universal hard drive adapter, not helping allowing me to read?

I bought a universal hard drive adapter, I tried to plug it in to my old i book G4 hard drive and it just won't read it. IT does't show up on my computer at all. I don't know what to do! I broke the screen from my old ibook g4 and just wanted to save the hard drive.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Two possible reasons:

  1. You probably don't have enough power from your USB port… or,
  2. you can not boot that age Mac from USB (Firewire or optical disk only).

The first could be solved , possibly by putting a self-powered USB hub inline between the computer and the "universal" adapter. or by getting a firewire ported external case for the ATA drive.

You should be able to access the data from the drive'' (but not boot from it)'' using your adapter to connect to a much news model Mac.

If this Answer is helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 2
Add a comment

Add your answer

xsvr94x will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 81