Fourth generation iPhone. Repair is straightforward, but the front glass and LCD must be replaced as a unit. GSM / 8, 16, or 32 GB capacity / Model A1332 / Black and White.

3210 Questions View all

Replaced battery won't work, stuck in boot loop

Ok, so my iPhone battery has become progressively worse over the last couple of months(or so..) so i thought it would be smart to replace it! but i didn't want to do ship it to an apple store and pay loads of money for them to do it, so i bought it myself. i opened the phone today, unscrewed the philips screw holding the battery connector in place, and the started trying to get the battery out, but it was really stuck in there, so it took a while to get it out, even had to put some guitar picks(thin) in there(but not where there was any cables

though). i finally got it out, so i simply put in the one, connected the cable, and then i tried to turn it on(with wall charger in of course), but it turns on for like 5 seconds, then turns off again(boot loop). i have reconnected it several times, and i tried to boot it without battery, and the same thing happens(boot loop). so i have no idea of whats wrong here, and i really don't think i have damaged anything in the process!


Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment
Deck the Halls
With tools and Fix Kits

3 Answers

is the replacement battery an OEM (from Apple) or is it a generic one? It could possibly be a defective battery. did you put the original battery back and see if it doesn't do the boot loop? if so, then you know the replacement battery is incompatible or defective.

Hope this helps. good luck!

Was this answer helpful?

Score 0
Add a comment

Try to turn it back on with the rear case off

Was this answer helpful?

Score 0
Add a comment

if the above both methods didnt worked.

try changing the bottom charging dock aswell.

bcz if thats not hardware fault (considering u havent broken anythng) then it should atleast boot without battery..

but its not doing that too so its posible botom charging port or battery or something on the board near battery connectors..

good luck.

Was this answer helpful?

Score 0
Add a comment

Add your answer

EndreI will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 4

All Time: 984