Mid 2010 Model A1278 / 2.4 or 2.66 GHz Core 2 Duo processor

786 Questions View all

I/O Errors after installing a new SSD

Hi there,

I have a I/O error problem after I installed an SSD to the original HDD bay of my MBP.

  • Model: MacBook Pro7.1
  • Year: 2010
  • CPU: Intel Core 2 Duo
  • OS X 10.8.5
  • RAM: 4GB


  • Samsung SSD 840 EVO 250GB (compatible with both SATA III 6GB/s and SATA II 3GB/s)
  • Model: MZ-7TE250BW
  • Firmware Revision: EXT0BB0Q

Bought a new Samsung EV0 840 (non-pro) installed as the main drive to my MacBook Pro 13" model 7.1, with SATA II. Installed Trim Enabler (Groths.org). From the very beginning for a couple of weeks the disk was producing I/O errors, sometimes even did not boot correctly. After a couple of weeks the SSD was dead.

Sent it back and received a new replacement.

After installing a new one, no matter whether enabled TRIM through Groths or Chameleon app I ran Blackmagicdesign Disk Speed Test and had again I/O errors after about 1-5 mins of the drive test. I disabled TRIM and the test went well for about 4 hours, but then again had the I/O error. After the I/O error had to take the SSD out, connect it externally via USB and run Disk Warrior to repair it to be be able to use it again.

After days of trials I gave up and put an old HDD back. Now testing the old one to see if the error still persist...

It has been quite a nightmare and I am thinking of either the MBP being dead, SATA cable to be replaced or the motherboard (logic board) dead....

Anyone experiencing similar issues? Any ideas about a potential cause of the I/O Error? Is Samsung 840 Evo 250 GB just a wrong pick and I should have chosen a different SSD?

Thank you very much

Answered! View the answer I have this problem too

Is this a good question?

Score 0


Jary - What is the OS you are using on this system?


Add a comment

1 Answer

Chosen Solution

I/O errors are often a bad cable. Apple and some third parties had a bad run of cables. I would start off replacing the SATA cable its self. I would also make sure you have the latest EFI firmware installed as well. Follow this Apple TN EFI & SMC firmware updates for Intel-based Macs.


The SATA I/O from your device and the given SATA standard your system offers are not the same so the device needs to adjust its SATA I/O to the speed of your system in this case SATA II (3.0Gb/s). While the Samsung EV0 840 sates it can work with SATA I or SATA II systems it needs to do this with the handshake the device does with the SATA controller. Some controller chips did have some problems handshaking correctly which is why you needed to update the systems firmware.

As to why the SSD has an issue where as the the HD doesn't has a lot to do with the speed of the data going across the SATA interface. (cable & connectors). As I stated Apple did have a problem with some versions of the cable which is the most likely issue here now that you had already the most current EFI & SMC firmware.

Just to be clear here you have this drive as a replacement of your HD and not using it in a carrier replacing the optical drive - Correct?

Was this answer helpful?

Score 1


Hi Dan, "I use OS X 10.8.5 (12F45)" I checked EFI and SMC versions. I tried to update the existing EFI&SMC and the EFI Firmware update 2.5 posted this during installation: "This software is not supported by your machine". I have EFI: MBP71.0039.BOE, SMC 1.62f7. The system requirement at the support.apple site states MAC "OS X 10.7.2", while I have a higher one 10.8.5. Perhaps that is already fine, right? I was thinking of the suggested cable change option and it is absolutely better than to consider a new logic board. I was just wondering if I have only problem with the SSD and up to now I haven't had any problem with HDD, would just the higher speed of the data flow (SSD) reveal a bad cable or bad cable is just bad cable and should have I/O error symptoms any time? Thank you very much for your help.


Yes your EFI & SMC are upto date: MacBookPro7,1 MBP71.0039.B0E (EFI 2.5) 1.62f7 (SMC 1.6)


Finally, nothing really helped and had to put back the old HDD- Back to 70's. Probably the SATA II of the logic board to blame, while Samsung SSD should be compatible with both. The HDD works fine. I hope someone from Apple or Samsung will soon update a firmware update to solve the issue.


Hi Dan,

I missed a part of your previous question. Yes, I put the SSD in the Mac's original HDD bay, not optical one. I will try to change the SATA cable, but given other limited options with firmware updates for both my MBP 7.1 and Samsung SSD I might be left with the only option to give back or resell the SSD and try to get one compatible with SATA II only, instead of SATA II and SATA III. I have heard that Crucial has quite good SSDs compatible with most MBPs, but again I would love to experiment rather less than more :-) Thank you


We started off going to dual drive setups using the optical drive then we went to hybrid drives (SSHD) as out staff complained about loosing the DVD player. We had used Samsung SSD's without any issues other than needing to replace the SATA cables on a few systems which had I/O errors like you are having so I do believe you'll be OK once you replace it.


Add a comment

Add your answer

JaryMachy will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 9

Past 30 Days: 30

All Time: 4,373