Skip to main content

Model A1311 / Mid 2011 / 2.5 & 2.7 GHz Core i5 or 2.8 GHz Core i7 Processor

427 Questions View all

HDD Fan speed 0, CPU fan speed at maximum

I tried to add a SSD, to my iMac 21.5 2011.

I followed the steps from the guides (iMac Intel 21.5" (Mid 2011) Dual Hard Drive Kit). I din't have a SATA power cable, so I used a power spitter. I took the power from the HDD and split it to the SSD.

The iMac found the SSD and its HDD, but the fans went crazy.

The optical drive fan works as it should (I left the thermal sensor). The HDD drive fan indicates 0rpm, and the CPU fan goes at full throttle.

I removed the SSD and left only the HDD. But the fans remained the same.

I also tried but it's not doing anything for the fans.

Any tips or info, that would help me solve this, is appreciated.

iMac Intel 21.5" (Mid 2011) Dual Hard Drive Kit Image


iMac Intel 21.5" (Mid 2011) Dual Hard Drive Kit


Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

2 Answers

Chosen Solution

Try an SMC reset - your kluge may have caused problems with the EFI. Fans run at high speed by default if temp sensors report out of range or failed (your HDD fan sensor could be the cause of the fan problem). If the reset doesn't work you'll have to figure out if a fan is indeed shot.

A fan control app should work - but with one fan out you could cook you CPU so I wouldn't use one anyway.

If this answer is acceptable please remember to return and mark it.

Was this answer helpful?

Score 1
Add a comment

I found the problem. I haven't connected the HDD fan to it's power socket. (>_>).

Was this answer helpful?

Score 0
Add a comment

Add your answer

Ispas Adrian will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 869