2.2, 2.4, 2.5, or 2.6 GHz Core 2 Duo processor

918 Questions View all

Keyboard wasn't working intermittently. Now MBP won't boot

Hi all,

First of all thanks for these very helpful guides. Here is my problem.

I have received a MBP on which the keyboard and trackpad intermittently stopped working. I knew it was a hardware problem as it happened straight at boot time.

I first suspected a loose connection, so I did steps 1 to 14 of this guide :

MacBook Pro 15" Core 2 Duo Models A1226 and A1260 Keyboard Replacement

And then reversed it. That way I had removed connections and put them back. Still no success.

I googled a bit more and found this :

http://lbarclay.wordpress.com/2009/01/29...

I tried it, and it worked perfectly. I just used electric tape to create a bump over the ribbon. When the battery went in place, everything worked perfect... For 2 hours.

I then wanted to check if the tape wasn't overheating, I removed the battery slot while the power was plugged. Computer powered off, and then wouldn't turn back on.

I went on and redid all the previous disassembly/reassembly with no success...

Any idea where this could come from??

Thanks a lot,

Simo

Update

A few more hints, dunno if they are of any use :

------------------------

- Tried booting WITH and WITHOUT battery in : Nothing

- Tried booting WITH and WITHOUT the power adapter : Nothing

- Tried moving/pressing the orange ribbon while trying to boot : Nothing

- Tried shorting the PWR solder dots : Nothing

------------------------

- I left the computer as it was (powered off) with the battery in and not plugged to the power for a few hours: The battery went from fully charged to fully discharged.

- After plugging in the adapter, the battery doesn't seem to be charging after 45mn (according to the owner, when her battery used to be fully discharged, it would always take 10 to 20 mn before she could power the MBP back up. Not using the original power adapter)

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

Note that NOTHING happens when pressing the power button. No fans, no lights. Nothing.

- Battery has 4 lights on

- Power supply shows green light when plugged in

by

Add a comment

3 Answers

Chosen Solution

The internal Powerbutton is located left to the right fan (can't describe that better). Just two solderdots marked "PWR". Use a magnifier, that helps. Shorten the dots with a screwdriver or similar. If it powers on - hey presto, you need a new topcase. ;-)

Was this answer helpful?

Score 1

Comments:

Sorry that nothing helped. The only thing you could try at this stage is removing the backup battery for a minute. It sits underneath the optical drive and is connected to the logicboard via a small 2 pin connector just north of the OD.

by

For info, I accepted this answer because it did answer my question about how to short the PWR, but it didn't fix the problem. Thanks anyway for your help :)

by

Add a comment

Very nice question, + vote. Try starting up with the battery removed. If that works you may need to rewire and reroute the wires.

Was this answer helpful?

Score 0

Comments:

I had tried it, unfortunately with no luck.

I have read that there were some "PWR" connectors that could be shorted to try and power it without the uppercase, but can't find them. Any idea where they are?

by

Add a comment

I finally found these PWR solderdots. They weren't anywhere that I read about. They actually were to the right of the memory slots :

Block Image

I tried to short them with power cable only, with battery only, and with both. None of it worked. No fan movement, no light, nothing :(

Any suggestion?

Was this answer helpful?

Score 0

Comments:

Sorry to have added this as a reply instead of comment, it was the only way I found to attach a picture.

by

Add a comment

Add your answer

No Spam will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 913