0

Score

Avatar
Jonathan
1

Asked

Replaced screen and digitizer, but touch doesn't work

History

My son's Asus T300 had a cracked screen and wasn't responding well to touch. So I purchased the replacement parts. I replaced the parts. I put the think ribbon back the one next to it with the tiny wires connected. But touch doesn't seem to work.

is there anything else I can try? Is there a software thing I have to do in order to get it to recognize the new hardware?

Add Comment Cancel

Post Answer

0

Score

Avatar
Chris Knight
1

Answered

PermalinkHistory

No answer for you but just went through the same thing. Never any problem with touch screen, then dropped and cracked screen. Didn't work. Bought new digitizer and just installed without sticky tape for testing purposes. Getting the same result. What else could have broke when I initially dropped it so only touchscreen would not work? Used the keyboard with it so I know everything else works.

Add Comment Cancel

0

Score

Avatar
mark
1

Answered

PermalinkHistory

Im having kind of the same problem. I am working on one for a friend and replaced the LCd and kept the digitizer. Everything went smooth. Until i was taking the digi from the lcd. A small crack near the bottom of the digi appeared but it was small and in the black bezel area. Got it back together and touch screen wouldnt work. Left it alone for a bit and got back to it and tried to seperate the digi from the lcd again. Another small crack formed. This time near the digi cable in the black outside area. Still not bad but this time i tried to really seal the digi back down on the lcd. I think the sticky pad around the outside is causing a bad buffer between the lcd and digi. When i tried the reseal now half the screen worked or slightly less. It sounds like its a matter of sealing up the digitizer to the lcd firm enough. Hopefully in my problem the second digitizer break didnt end all hope.

Add Comment Cancel

0

Score

Avatar
Chris Knight
1

Answered

PermalinkHistory

Mark,

I found that the digi and the lcd work independent of one another. There is nothing to worry about the"buffer" between the two. In my case, the first digi I got the ribbon/glass connection point started peeling up and I got intermittant operation. (Luckily I didn't stick everything together yet). With my second digi I got, intermittant operation again. Eventually found that the connector, both digi and lcd were finicky. I used the sticky and the existing foam rubber to help keep these connectors in place. Everything good now.

Add Comment Cancel

0

Score

Avatar
jose
1

Answered

PermalinkHistory

hola yo cambie touch sren estrellado ya no funcionaba nada compre el digitalizador nuevo me costo trabajo despegarlo del lcd pero o consegui los adesibos se dañaron los sustitui or cinta adhesiba doble por ambos lados sellando perfectamente lcd y touch acontinuacion de terminar de armar al encender el digitalizador touch nuevo no funciona nada como al principio con el estrellado

Add Comment Cancel

0

Score

Avatar
mark
1

Answered

PermalinkHistory

Hmm just replaced the digitizer and touch screen does not work. But it did not work before the change because the old digi was cracked all over. Lcd is good however.

Cables look like they are in all the way and snug. Could i need to reset the software through the software? Maybe the new digitizer is bad?

Add Comment Cancel

0

Score

Avatar
Chris Knight
1

Answered

PermalinkHistory

Mark,

The 2 connectors, lcd and digitizer, are finicky on mine. I had to take tablet apart a couple times to "reconnect" them. I used masking tape to better hold them securely. A loose ribbon cable connector means no digitizer operation. A loose fine wire connector in the center of tablet means no lcd operation. Good Luck

Add Comment Cancel

0

Score

Avatar
mark
1

Answered

PermalinkHistory

Chris. I have checked and rechecked cables. I now have another digitizer brand new to try out. Still nothing not even intermittent touch. The only thing i have found is the ribbon from the digi board to the main board has one contact kinda scrunched up. It seems like its in far enough to get past the scrunched up part. But even so wouldnt there be intermittent touch?

Could the digi board be bad somehow. ...

When i first did the replacement the screen was working even after i changed the lcd and the old digi first cracked. Cant remember when the digi stopped working all together. But i suspect this ribbon cable and have ordered a new one. Ughhhh, I would say ill never repair another one of these but my experience with them now is getting in depth.

Add Comment Cancel

0

Score

Avatar
mark
1

Answered

PermalinkHistory

So i have replaced the digitizer board ribbon that connects to the main board. I found that two of the contact points were bent up and peeled back or tweaked. SO i replaced that.

So for all who are taking notes.

broken lcd problem, replaced lcd while replacing cracked digitizer. Touch started working spotty if not at all.

replaced digitizer, touch not working at all. checked and rechecked ribbons.

Replaced main digitizer - main board ribbon. no touch. rechecked all connections.

next step.... replace digitizer board? I guess its at this point. The only thing i can figure is the bent/tweaked connections on the main ribbon shorted the board?

One question i have and cant remember is could the lcd be the wrong version? I know the digitzers make a difference. And i have the exact match of digitizer. But i did not know of other versions of LCds. I have not heard that there is other versions just I wonder if there is and that is why the touch is not working.

On you tube there is a video of a factory repair where the factory sent it back to the owner saying they could not find out the problem. And it has a no touch problem also. I hope that is not the case or else im buying a new tablet for someone.

Definitely look into "exact" part #'s when it comes to digitizer, there are revisions, look into it

Jonny Blazin,

Definitely look into "exact" part #'s when it comes to digitizer, there are revisions, look into it, also the same can be said for LCD replacement.

Jonny Blazin,

Add Comment Cancel

0

Score

Avatar
Juan Garcia
1

Answered

PermalinkHistory

asus transformer t300t have three differant digitizer you need the same one near the ribbon there is a white sticker with writing on it only and nothing under on some some have white numbers and letters under sticker look at the last three might say g01 or g03 it has to be the same one other wise wont work just like the xbox 360 they have differant dvdroms some toshiba,samsung ben-q and so on if uyou but differant brand the xbox dvdrom wont work some how asus transformers are the same way

Add Comment Cancel

0

Score

Avatar
Mark Mata
1

Answered

PermalinkHistory

Oh i forgot to post the fix to this issue.

I was so happy when i found an answer. There was this forum with somewhere near 80 pages of answers and comments. In the middle of it was a solution to repair a small micro fuse located just below the cable that goes from the main board to the digitizer board. If you notice carefully it can get burnt.

This happens when the unit is not powered down and the digitizer is detached or disconnected. I could not power mine down so i thought because the digitizer was unresponsive to touch. But what i did not know is there is a shutoff switch near the power button. its a slide switch.

So once i figured out what the issue was i ran a super fine wire from one side of the micro fuse to the other and soldered it in. It was tough but it worked!!! like a champ.

Hope this helps any with this issue. I spent a lot of time and money when it was just simple fix.

Add Comment Cancel

0

Score

Avatar
cozni
1

Answered

PermalinkHistory

Hi Mark,

I found your very useful. I have a TF700 and got the same symptom than you had. I didn't disconnect the power while replacing my broken digitizer by a new one. I guess this is why my touchscreen stoppped working since...

Would you know where is that micro fuse located exaclty? I have not been able to find it. My electronic knowledges are a bit rusty. I am looking for a little "F" (for fuse) somewhere on the digitizer or main board, but cannot find one.

Would remember where that forum you fond the answer is?

Also, my batterty is showing has empty when I power up the tablet, did you have the same symptom?

Thanks

Add Comment Cancel

0

Score

Avatar
mark
1

Answered

PermalinkHistory

http://forum.xda-developers.com

It was in this site. I dont have time to go through it again. But if you search the tf300t forum for Coil you will find the right place just research and you will find it.

Add Comment Cancel

0

Score

Avatar
fuad
1

Answered

PermalinkHistory

maybe you didn't placed the cable to socket firmly. i have experienced that. sorry for may bad english

Add Comment Cancel

Add Your Answer

View Statistics:

Past 24 Hours: 62

Past 7 Days: 345

Past 30 Days: 1,432

All Time: 17,061