MacBook Pro will only start in 'safe' mode, why is this?

2007 MacBook Pro Intel 2.33GHz 17in 3GB RAM

I have a 2007 MacBook Pro that will start normally with the chime and Apple logo. I also get the gear wheel underneath but then that screen just goes to a blank grey screen and nothing further happens.

I tried to reinstall using a retail Snow Leopard from DVD but starting up using the 'C' key ends up with the same result.

I then used my iMac to install 'Lion' onto another hard drive I have and installed that into the MacBook Pro. Yet again the machine displays the same behaviour.

The only way this machine will boot is in 'safe' mode (starting while holding down 'Shift') Once it had booted I used Disk Utility to repair Permissions and noted that it appeared to repair lots of files relating to the display.

I also plugged in an external display and that worked fine, so I rebooted normally with this also connected and again got to the white/grey screen.

I have two RAM chips - a 1GB Samsung and another 2GB Kingston. I removed the Kingston and tried just with the Samsung - no change. I swapped out the chips - no change.

I have again tried to boot from another installer DVD - this time 'Snow Leopard' and I just cannot get the machine to complete start up.

It's doing my head in!!!

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Apple MacBook Pro "Core 2 Duo" 2.33 17" Specs

Identifiers: Core 2 Duo/Late 2006 - MA611LL/A - MacBookPro2,1 - A1212 - N/A

by

Add a comment
Deck the Halls
With tools and Fix Kits

2 Answers

Chosen Solution

Using Disk Utility from the drive you are trying to repair does not work very well. Use you other machine and a firewire cable to start in Target Mode, here's how: http://support.apple.com/kb/HT1661

I would then use Disk Utility from the iMac to repair the disk and permissions. This failing, use Target Mode to reformat the drive (use the "write zeros option), this will map out any bad blocks that may have developed. Now you should know if the drive is any good. If so install a new system from your Optical drive.

Was this answer helpful?

Score 1
Add a comment

Hey Guys,

Same machine, Same problem here :)

I found the problem and it's coming from a faulty GPU (Graphic card ATI X1600) o the logic board.

Only solution, change the logic board, which cost !@#$ a lot or try the "Oven logic board" Solution.

I found a way to counter the problem at the moment and it's to disable all the drivers from your ATI GPU i sae mode and so you can start easily in normal mode, except the Graphic chip wont be considered, so hard to watch HD movies or using VLC, ect..

But it is a temporary slution and it is working fine.

Let me know if you want further information on this solution.

Cheers,

Loic

Was this answer helpful?

Score 0

Comments:

Hi Loic,

How did you disable the drivers from the ATI GPU?

Thanks,

Duane

by

Hi Loic,

How did you disable the drivers from the ATI GPU?

please respond

luqman.brac@yahoo.com

by

Add a comment

Add your answer

Richard Ellis McCallum will be eternally grateful.
View Statistics:

Past 24 Hours: 20

Past 7 Days: 146

Past 30 Days: 682

All Time: 19,896