Model A1137 / 1, 2, or 4 GB capacity / black or white plastic front

82 Questions View all

Battery Change Didn't Cure My Problem

1. I changed the battery and the Nano seemed to work fine for a day ot two. Now the same condition reappeared of no battery charge. It only plays when powered by external device like Docking Station or when plugged into the computer.

Any suggestions?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

sounds like the new battery is empty or there is something wrong with the power circuit - something drains the battery - was there a fluid damage or something like that ?

Was this answer helpful?

Score 0

Comments:

Hello,

Thank you for taking the time to respond. I was also thinking that maybe that something could be wrong with the power circuit resposnible for recharging. Ifixit is sending me a replacement battery. This one will tell the story but I dread reopening that Ippod. No no battery leakage.

by

opening the first gen. isn't that bad - newer ones are horrible ;-)

dorry - i didn't mean a battery leakage - i ment water or any other "non technical" fluid

sometimes the slightest fluid damages could make problems - check and maybe clean the dock connector with a paintbrush and rubbing alcohol.

i've seen this many times on cell phones - a little damage (or dirt) on a dock contact could be able to make charging problems

by

Add a comment

Add your answer

tomasnie will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 616