Skip to main content

Fix Your Stuff

Right to Repair

Parts & Tools

7.9 inch display / Model A1432 / Available in black or white / Announced October 23rd, 2012 / 16, 32, or 64 GB capacity

245 Questions View all
Question Closed

iPad Mini can't get past apple logo after screen repair

I have repaired a few ipad minis and never had problems. This one though, is killing me.

I removed old digitizer, took out old lcd, unplugged battery, but new digitizer back in, put lcd back in, plugged battery back in and went to power up to test.

Apple logo, awesome! but then after several seconds on the logo, it fades out pretty quick and reboots the ipad and does it all over again.

Ive tried other digitizers, i've double checked everything I could, tried restore (error 9), etc. Made sure no debris anywhere inside causing a short.

Any ideas?

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

Tried a new battery just to see.. same result :(

by

Add a comment

Manta Driver Kit

112 bits for every fix.

Upgrade Your Toolbox

Manta Driver Kit

Upgrade Your Toolbox

1 Answer

I doubt that the digitizer is what is causing the issue. It's likely something else.

The first thing I would do to troubleshoot:

Restore the iPad in iTunes (hopefully you have a backup) you may need to place the iPad in DFU mode to get the restore to work.

Let me know how this goes!

Was this answer helpful?

Score 0

Comments:

Already tried restores as mentioned in both regular and DFU modes, still no luck. Same "fade out" apple image right as it appears to be copying over the files

by

Add a comment
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 283