Repair and disassembly guides for the Apple AirPort Extreme Model A1143.

10 Questions View all

After upgrading to 7.4.2 Air Disc won't connect anymore.

Hey folks!

I recently updated my AEB to 7.4.2 and it turns out that my MacBook is not able to connect to the Harddrive connected to the AEB. When 7.4.1 was installed (and after downgrading Firmware to 7.4.1) it worked and I could even use it for Backups with TimeMachine.

It's a used AEB, bought on Amazon a year ago, or so. That's why I don't know when it was built etc. But the Model No. is A1143, if this helps.

Would be thankful for any advices.

greets [m]

Answered! View the answer I have this problem too

Is this a good question?

Score 2
Add a comment
Black Friday
Broken doesn't stand a chance.

1 Answer

Chosen Solution

There seems to be a lot of issues with 7.4.2 version firmware for the Airport Extreme. Mine would lose connection to the disks regularly, and I'd have to restart the basestation (switch off or restart via Airport Utility) to get the connection back. I tried many things to resolve this, but nothing worked and in the end I rolled-back to 7.4.1 and everything is fine now, and has been for several months - much more reliable connection to disks attached to the basestation. So that's what I'd recommend.

The only issue is that Airport Utility sometimes warns me that a 'basestation is reporting issues" - that is just the basestation seeing there's a firmware upgrade available. Just ignore it.

This isn't really a fix, but it seems the only workaround I can find. Hope it helps.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Mario Schmiedel will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 8

All Time: 1,610