Model A1312 / Mid 2010 / 3.2 GHz Core i3 or 2.8 & 3.6 GHz Core i5 or 2.93 GHz Core i7, ID iMac11,3

296 Questions View all

New WD Hard Drive won't Format

Old 1TB hard drive went bad so I replaced it with a new 2TB drive from ifixit site. Same manufacturer. Followed repair instructions taking care to note all plug pin locations.

After reassembly and booting from SnowLeopard CD, I ran Disk Utilities. The drive appears and is listed as WDC WD20EZRX-00D8PB0 Media. Under the erase tab it says total capacity is 0 bytes and Partition Map says unformatted. It's a new drive and needs to be formatted, fine. But the Erase button, Format menu, and Name field are all dimmed. Nothing in Disk Utils will get that Erase button dark.

So I disassembled and unplugged/replugged all connections, rebooted from CD, tried Disk Utility again, but there was no change.

Is this a bad drive?

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

2 Answers

Chosen Solution

See if this writeup helps you in prepping your HD The Master Guide to Formatting a Hard Drive.

As you don't have anything on your disk Erase is not an active option. First partition the drive with one or more partitions. I like two one for my OS & Apps and the second for my data that way I only back up second data partition every day and backup my first partition when I update or add in any new apps. You might want to leave some space if you plan to use BotCamp with MS Windows or think you might use another OS. Apple by default setup the system with one partition. Then you can format the partition/s as needed.

Was this answer helpful?

Score 2


Thanks for responding. The Partition tab has a dimmed Name field. The Size field doesn't let me type anything into it. The Format menu is dimmed. The Volume Scheme shows nothing and clicking the + button to add a partition does nothing. (I do have the new drive selected in the left hand column.)

There is a message above the dimmed Apply button that says: This disk is too small to contain partitions.

This is a fresh disk so we're trying to initialize it, not partition it.


The only thing left is the SATA speed of the drive & what the system can handle. Looking up the WD drive we find it is a SATA III (6 Gb/s) drive HD Spec sheet. Looking up your system we find it's HD interface is SATA II (3 Gb/s) Systems specs. Heres the WD support doc on the jumper settings on your drive. You will need to set it for SATA I/II mode 1.5/3.0 Gb/s for this drive to work WD PATA & SATA jumper select.


OK. Thanks for the direction but this is not working out. Just spent last 6 hours trying to get this drive working.

First off, that page of jump settings doesn't apply because the iMac comes with a jumper block already installed. This is the jumper block that everyone tells you you can't mess with otherwise the fan will run at full speed. The jumper block is big enough for 3 sets of pins but it's only using 2 sets. So on the off-chance that it really was the jumper settings I moved the block and put everything back together again. No change. Tore it down again and moved the jump block. Rebuild. No change. Repeat and repeat again to cover the 4 possible positions of the jump block. All for naught.




Research online showed that other people were able to bypass the problem by putting the drive into an already running Mac, initialize it there, and then move it back into the target iMac. So I installed it in a Mac tower and got exactly the same problem and message "This disk is too small to contain partitions."




So at this point it doesn't work in two different machines using two different OSs and the jumper idea doesn't work either.


Unless you have another suggestion I'm considering this drive DOA.


By the way, the formatting in this comments area appears to be broken. I've inserted dashed to show where the paragraphs were supposed to go.


The jumper block I'm pointing you to is on the HD, not on the system. I often need to alter the drives settings to match the systems SATA I/O speed.


Show 6 more comments

Add a comment

I've had the exact same issue with my WD hard drive in me 21-inch iMac. Everything greyed out in disk utilities no matter what I do. It seems the problem is some kind of thermal sensor kit that OWC provides. 2009-2010 iMacs all seem to require it for third-party drives. Sigh. I am going to call them and ask them if not using this kit will result in the problem we are having.

Was this answer helpful?

Score 0


@spudner - If you have installed the in-line thermal sensor is not the issue here. If you haven't then you likely need it ;-} As your system is running the fans hard which is not good for the system.

As to why Disk Utility is greyed out. There are a few reasons this can happen.

- You didn't boot up under a different drive

- You've booted up with an older version of MacOS than what you are running on the system (this is true with High Sierra)

- The drive is encrypted


Add a comment

Add your answer

zax will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 4

Past 30 Days: 12

All Time: 1,979