Model A1238 / 80, 120, or 160 GB hard drive / black or silver metal front

865 Questions View all

No music after replacing logic board

My ipod classic 120g wouldnt play music out of the connection port unless it was bent down, I just got done with replacing the logic board, all is working and functioning except it shows no music on the HD and will not connect to itunes. My computer gives me an unknown device connected error. Is it the HD cable to the logic board now?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Make sure that you inserted the cable into the HDD connector properly (make sure the drive is not upside down;-) Also, you did not tell us if this is a new logicboard or used. Try to place it in disk mode (as well as diagnostic mode)and see what you get. Use the same computer you used to use with your iPod all along.

Was this answer helpful?

Score 1

Comments:

I've tried removing and replacing the hdd cable multiple times with no avail. I hear the hdd click like it used to when I turned it on, like its working, but still nothing. How do I put it in disk mode, or diag? It is a new not used logic board. And yes it's the same pc I have used since I bought the iPod a couple years ago. Thanks for the reply.

by

Googled disk mode, got it done and itunes is now syncing. Thanks for the info, looks like its working.

by

Add a comment

Add your answer

Kyle will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 74