Model A1297 / 2.66, 2.8, 2.93, or 3.06 GHz Core 2 Duo processor

1069 Questions View all

Why is my SSD not recognized during 10.6 installation?

MacBook Pro 17" Unibody - Mid 2009 A1297

Hello, new mac owner here. I've got an ADATA SP900 SATA III 6gb/s internal laptop SSD which I was hoping to drop into my Macbook Pro. I know this is a good drive as I pulled it from a Windows laptop that was using it as its primary. When I boot from the 10.6 install CD the SSD does not show up in the list of drive choices to install onto.

The funny thing is, I thought perhaps the drive needed to be formatted first. So I restarted and booted from GParted live disc. The drive shows right up in GParted. I erased the drive and tried installing OS X 10.6 again. The drive is still not recognized in OS X live install.

I had a spare HDD lying around so I installed that and lo and behold, the drive was recognized. I have since installed onto that, but would much rather prefer to run off my SSD as opposed to an HDD.

So, to summarize:

SSD not populating in drive list during initial install of Mac OSX10.6.

SSD recognized and read in GParted live disc.

Chassis recognized different HDD without issue.

SSD is known good, pulled from other laptop.

Is there a possible hardware support issue I don't know about? Perhaps this model doesn't support SATA III ? I was pretty sure that SATA III is backwards compatible.

Anyone else run into this issue?


Answered! View the answer I have this problem too

Is this a good question?

Score 0


Can you supply the last three digits of your serial number so we can correctly identify your model.


Add a comment

2 Answers

Chosen Solution

MS Windows uses a different format than Mac OS-X. You will need to use Disk utility to format the drive first.

Was this answer helpful?

Score 2


DIsk utility from OS X 10.6 install doesn't list the SSD as an option to format. I did format the SSD to HFS+ using GParted Live. So it has been formatted outside of the installer.


The last 3 digits of my serial number are '8YB'.

I've done a little bit of digging and it appears I am not alone with SSDs not showing up in Disk Utility on Mid-2009 MBP. A lot of others are having the same issues. Some are having success with downgrading from EFI 1.7 to EFI 1.6 and even then, having spotty SSD performance. I will likely just stick to an HDD unless someone has some other suggestions.


Your system's SATA port is too slow for your SSD (SATA III 6.0 Gb/s). You'll need to get a different SSD. As to using 1.6 Vs 1.7 EFI version I don't know were people thought that would make it better. The difference between the two is some models had a newer SATA controller which could run SATA II (3.0 Gb/s) over SATA I (1.5 Gb/s) which the EFI firmware enabled. Sadly, your model doesn't have the newer chip. The newer 1.7 has some other things you do want so please go back to it.


Well that's a bummer. I guess I can't complain too much. Got a pretty good deal on the MBP. Will just have to use an HDD.

Thanks guys!


Add a comment

If all else fails, replace the hard drive cable.

Was this answer helpful?

Score 1


I don't believe it is the hard drive cable as I am using a regular HDD connected to that same cable right now.

Thanks for responding though!


Add a comment

Add your answer

Tyler will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 3,932